MMarko

Well-Known Member
Apr 18, 2005
316
0
166
cgarvey said:
So in /usr/lib/perl5/site_perl/5.6.1/i686-linux/DBI.pm I changed line 275+ to , to always return fals for the check (because, Scalar::Util warns me it's not available).. that stops the error I reported above from happening, and doesn't seem to break anything else (if there is a check in DBI, there is the implication that it's OK to not have it!).

Hm, your fix worked. I have perl 5.8.0. on CentOS 3.6 x86_64 (well Chirpy it seems you were right about x86_64 linux, but this seems the only issue I couldn't not solve).


I've been getting:

/scripts/runlogsnow
Resetting Logs for pef007...Done
(internal death) Sun Feb 12 22:11:25 2006 [7453] error: Modification of a read-only value attempted at /usr/lib64/perl5/site_perl/5.8.0/DBI.pm line 279.
eval {...} called at /usr/lib64/perl5/site_perl/5.8.0/DBI.pm line 276
require DBI.pm called at /usr/lib64/perl5/site_perl/5.8.0/DBD/mysql.pm line 7
DBD::mysql::BEGIN() called at /usr/lib64/perl5/5.8.0/x86_64-linux-thread-multi/Scalar/Util.pm line 0
eval {...} called at /usr/lib64/perl5/5.8.0/x86_64-linux-thread-multi/Scalar/Util.pm line 0
require DBD/mysql.pm called at /usr/local/cpanel/cpanellogd line 60
main::BEGIN() called at /usr/lib64/perl5/5.8.0/x86_64-linux-thread-multi/Scalar/Util.pm line 0
eval {...} called at /usr/lib64/perl5/5.8.0/x86_64-linux-thread-multi/Scalar/Util.pm line 0
[a fatal error or timeout occurred while processing this directive]==> cPanel Log Daemon version 22.2
==> Shared RRDTOOL support enabled
I've tried to install perl 5.8.7 but everytime it downgrades back to 5.8.0. Any ideas why?
 

MMarko

Well-Known Member
Apr 18, 2005
316
0
166
One notice - my stats didn't stop working. Everything was fine except I've been getting those perl error messages.

Stats are updating just fine.
 

rip_curl

Well-Known Member
Jan 30, 2005
82
1
158
I have perl 5.8.7 installed on my server. But in https://server.com:2087/cgi/statmanager.cgi
I see:

The server is having trouble keeping up with your statistics processing schedule. You should increase the time between statistic generation, or upgrade the server. If you have recently decreased the time between statistic generation, you may wish to wait that amount of time to see if the server will catch up before changing back.
Show which users are behind
how can I fix it?
can you tell me step by step?

Also I have often my cppop failed, waht can it be? help please.
 

rip_curl

Well-Known Member
Jan 30, 2005
82
1
158
[email protected] [/usr/lib/perl5/site_perl/5.8.7/i686-linux]# /scripts/runstatsonce
This script requires cPanel 6.4.2 Build 11+

==> WARNING: configured processor count does not match
==> actual processor count (2)! Running stats programs
==> on this system may cause excessive load!
==> You should set extracpus=0 in /var/cpanel/cpanel.config if this is not ok.
==> cPanel Log Daemon version 22.2
==> Shared RRDTOOL support enabled
==> Ignoring lastrun files and running all stats now
==> cpanellogd will exit after stats have run
 

xidica

Well-Known Member
Apr 21, 2005
63
0
156
Texas
After upgrading Perl on literally 500+ RHEL3 boxes, here is my fairly definite guide to ensure perl and it's modules are updated correctly :

Line 11 of /etc/inputrc will frequently the following error with /scripts/perlinstaller (or the perl CPAN install module) :

Warning [/etc/inputrc line 11]:
Invalid variable `mark-symlinked-directories'

Comment out the following entry in /etc/inputrc out :

set mark-symlinked-directories on

Now :
cd /root (or wherever has a little over 110MB of space free)
wget http://layer1.cpanel.net/perl587installer.tar.gz
tar -xvzf perl587installer.tar.gz
cd perl587installer/
./install

After this completes, for good measure :

/usr/local/cpanel/bin/checkperlmodules
perl -MCPAN -e shell
cpan> reload cpan
cpan> reload index
cpan> quit

After this, the obligatory upcp should finish it out...let me know if I've missed something.