The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stats wont update

Discussion in 'General Discussion' started by ahostli, Feb 17, 2009.

  1. ahostli

    ahostli Active Member

    May 28, 2006
    Likes Received:
    Trophy Points:

    Ive noticed that on all of my servers stats arnet updated. Nor analog, nor Awstst (Webalizer somehow gets uppdated but it gives only basic information about hits to erbsite). So Ive disabled Analog ar Webalizer and left only with Awstats, but five days passed and no updates.

    As I see from WHM > Statistics software configuration - The server currently is able to keep up with your statistics processing schedule, domlogs are rotated.

    Running /scripts/runweblogs USER gets foolowing errors:

    Searching new records from beginning of log file...
    AWStats did not find any valid log lines that match your LogFormat parameter, in the 50th first non commented lines read of your log.
    Your log file /usr/local/apache/domlogs/ must have a bad format or LogFormat parameter setup does not match this format.
    Your AWStats LogFormat parameter is:
    This means each line in your web server log file need to have "combined log format" like this: - - [10/Jan/2001:02:14:14 +0200] "GET / HTTP/1.1" 200 1234 "" "Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)"
    And this is an example of records AWStats found in your log file (the record number 50 in your log): - - [17/Feb/2009:11:54:52 +0200] "GET //worker.php?command=cpu_auslastung&auslastung=0 HTTP/1.0" 200 0
    Setup ('/home/user/tmp/awstats/' file, web server or permissions) may be wrong.
    Check config file, permissions and AWStats documentation (in 'docs' directory).

    So I figure, that the problem is caused by domlogs beeing loged in common format, not combined. But I wasnt able to change domlog logs format via httpd.conf settingings:

    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common
    LogFormat "%{Referer}i -> %U" referer
    LogFormat "%{User-agent}i" agent

    CustomLog /usr/local/apache/logs/access_log combined

    Sets only access_log to combined.

    So the question would be how to set domlogs to combined Logformat, or is there any othes way to solve?

    P.S. WHM > Basic setup Apache log format is set to combined.

Share This Page