The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stats

Discussion in 'General Discussion' started by Mr Terrence, May 20, 2005.

  1. Mr Terrence

    Mr Terrence Member
    PartnerNOC

    Joined:
    Oct 9, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Toronto, Canada
    cPanel Access Level:
    DataCenter Provider
    :confused: Hello, one of our clients is having alot of problems with stats software. They will run for about 5-6 days and then stop recording. Does anyone know what this problem might be??? :confused:
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Most likely they not running due to high load average. You could try increasing WHM > Tweak Settings > The load average above the number of cpus at which logs file processing should be suspended, though dealing with any load problems would be the priority.
     
  3. Mr Terrence

    Mr Terrence Member
    PartnerNOC

    Joined:
    Oct 9, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Toronto, Canada
    cPanel Access Level:
    DataCenter Provider
    How do we start the stats software again? :confused:
     
  4. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Hey,

    You can run this stat software using the following command
    /scripts/runstatsonce


    And another reason is user is over quato

    Just check this. Size of domlogs files is also another reason.. Go to WHM >> Sever setup >> Tweak setting >> stats and logs and enable the check box [ Delete each domain's access logs after stats run]
    -----------------------------------------------------
    Please check the following

    WHM->Add-ons->Schedule Statistics Log Times
    *has all 24 periods checked to disallow logs, effectively turning it off.
    *
    (also check the *"Log Cycle:" setting while you're in there checking)

    *You should allocate enough time. if there isn't enough time allocated to running
    *log analysis, your logs may never fully be completely analyzed.
    ------------------------------------------------------
    If the logs are nearing/over the OS filesize limit
    The solution is to empty the stats logs, /scripts/fixwebalizer may help
    or cd /usr/local/apache/domlogs

    echo " " > <the particular domains files>

    Then run the following command
    /scripts/runstatsonce

    If the problem exist only few users clear the domlogs and run the following command

    /scripts/runweblogs <username>

    May be this will help you to solve your problem
     
  5. Mr Terrence

    Mr Terrence Member
    PartnerNOC

    Joined:
    Oct 9, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Toronto, Canada
    cPanel Access Level:
    DataCenter Provider
    We found the problem, the reason it isn't running any more is because the log file for the domain on the server was too large. At that point, syslogd will not continue to log to it since it will slow down your system. To fix this, we have selected this option in WHM->Tweak Settings:

    Delete each domain's access logs after stats run

    This should took care of it.

    thanks for all your help guys... :D
     
Loading...

Share This Page