The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Still getting unroutable mail domains with phpsuexec installed

Discussion in 'E-mail Discussions' started by jackie46, Sep 23, 2005.

  1. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    Exim 4.52, S21

    I thought that with phpsuexec installed and the option in whm checked "Prevent the user 'nobody' from sending out mail to remote addresses (php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively.)" that unroutable domain error issues were of the past. Not so, we are seeing lots of unroutble domain errors. Here is one.

    2005-09-23 17:43:42 1EIvKY-0001iH-9b H=(net-promotion-mx.net) [69.44.140.8] sender verify fail for <bounce-418C8966C1@net-promotion-mx.net>: unrouteable mail domain "net-promotion-mx.net"

    A dig on our server reveals.

    dig net-promotion-mx.net

    ; <<>> DiG 9.2.1 <<>> net-promotion-mx.net
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16995
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;net-promotion-mx.net. IN A

    ;; ANSWER SECTION:
    net-promotion-mx.net. 86364 IN A 66.148.74.21
    net-promotion-mx.net. 86364 IN A 66.148.74.22

    ;; AUTHORITY SECTION:
    net-promotion-mx.net. 259165 IN NS ns1.puredns.com.
    net-promotion-mx.net. 259165 IN NS ns2.puredns.com.

    ;; ADDITIONAL SECTION:
    ns1.puredns.com. 155522 IN A 64.94.117.200
    ns2.puredns.com. 155522 IN A 63.251.83.79

    ;; Query time: 14 msec
    ;; SERVER: 207.44.136.111#53(207.44.136.111)
    ;; WHEN: Fri Sep 23 17:44:17 2005
    ;; MSG SIZE rcvd: 149

    Whats up with this?
     
    #1 jackie46, Sep 23, 2005
    Last edited: Sep 23, 2005
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I've seen this with a client. Since you are using phpsuexec there's no need at all to have the option selected anyway, so you may as well unselect it and it should then work fine. If it doesn't, you'll need to log it with cPanel through your license provider.
     
  3. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    Right, but we were getting them before checking the option as well!
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Try this:

    rm -fv /etc/eximmailtrap

    If that does delete a file then it should be OK.
     
  5. kofi

    kofi Well-Known Member
    PartnerNOC

    Joined:
    Feb 3, 2004
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    It amazes me the sheer number of bugs which get introduced into the stable releases in cPanel! Its becoming a weekly/daily ocurrence.
     
Loading...

Share This Page