The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stop all email with FROM user@host.serverdomain.com Is this possible?

Discussion in 'E-mail Discussions' started by jols, Mar 6, 2012.

  1. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    Hi,

    I am getting pretty tired of hackers getting into a out-of-date WordPress installation then uploading a simple script to broadcast spam, which always goes out as:

    FROM: user@host.serverdomain.com

    Now, is there a way to block such email using the anyname@host.serverdomain.com, EXCEPT, root@host.serverdomain.com?

    I still need to receive system messages of course (sent from root@host.serverdomain.com), but I would like to force all hosted users to use well configured scripts that have a valid reply-to/FROM of simply user@hosted-domain.com

    Possible?

    Thanks a bunch!
     
  2. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    Okay, I "think" I answered my own question.

    I have now changed the server contacts so that none of them are sending to "root":

    Main >> Server Contacts >> Change System Mail Preferences

    All three fields now contain regular email addresses.

    Now I am just trying to figure out, if it is okay to block any email with FROM: any@host.serverdomain.com and what is the best way I would go about doing this.
     
  3. ruzbehraja

    ruzbehraja Well-Known Member

    Joined:
    May 19, 2011
    Messages:
    383
    Likes Received:
    7
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Your first step should be to get the Wordpress installation upgraded. Until you do this, it wont help doing much.

    It takes about 30 seconds.


    Have you enabled:

    WHM >> Prevent “nobody” from sending mail

    Are you using suPHP?

    Have you enabled the domains max hourly email limit?
     
  4. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    Thanks for the reply.

    To answer your questions from the bottom up:

    Yes, yes, yes, and regretfully WordPress is not the only problem in this regard. Also, we often go through all servers and tell our members to update their WordPress, but then even if they do, it is rarely kept up to date in the months ahead. So the next step is to block the most common spam broadcasts that contain the most common FROM in the header.
     
Loading...

Share This Page