Stop Exim Sending "Mail delivery failed" Emails

loginid

Member
Jun 17, 2015
6
0
51
London
cPanel Access Level
Website Owner
Hi All,

Ok - I have looked and looked for a solution for this.
It seems like an easy fix, but I just can't find the right config for exim.

Where is the config option to stop Exim sending those pesky
"Mail delivery failed: returning message to sender"

Bounce messages?

My problem is that they're being sent to spammers who do not pass the spam rules.

Thank you!
 

loginid

Member
Jun 17, 2015
6
0
51
London
cPanel Access Level
Website Owner
For anyone else who wants to be able to stop the bounce messages for spam emails, I have found the solution.

Change this option:

Exim Configuration Manager ->
All ->

- Removed -

Apache SpamAssassin™: bounce spam score threshold ->
  • No bouncing by spam score default
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello @loginid,

I'm happy to see you found a suitable solution. Thank you for sharing the outcome.
 

Cistech

Registered
May 12, 2015
3
0
51
Argentina
cPanel Access Level
DataCenter Provider
Hi, I created a custom filter in Exim to avoid receiving one specific @domain.com spam emails, and used un Filter Tab for the hole server.

But emails are still being returned to false sender "Mail delivery failed: returning message to sender".
I cannot use Greyfilter here because some issues with good senders.
And option "Apache SpamAssassin™: bounce spam score threshold ->" proposed doesn't work because filter is at Exim no SpamAssassin.

Do you know how to disable "return message to sender" on Exim? Or what do you suggest?
I want to stop theses emails. They are scored as spam correctly by spamassasing, but they are sending a lot.
I'm using spamcop and spamhouse RBL ok, but this spammer not listed because is using different residential connection to connect directly to the server.

Thanks in advance
JC
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello JC,

Can you let us know the full custom filter rule that you added?

Thank you.