The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stop mail to domain completely?

Discussion in 'E-mail Discussions' started by xsenses, Jan 17, 2008.

  1. xsenses

    xsenses Well-Known Member

    Joined:
    Aug 29, 2002
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Huntington Beach, Ca
    I have a domain that does not currently use any email, but it seems the spam going to the default box exceeds the mailbox size and then it starts to backup in the que. Is their any easy way to kill the email to the domain completley or another solution?
     
  2. Stefaans

    Stefaans Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    451
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Vancouver, Canada
    If you remove the domain from /etc/localdomains, Exim will no longer accept any email for it. To be sure the domain does not get added back to /etc/localdomains (by cpupdate), do add it to /etc/remotedomains.

    The reason why you are experiencing this problem in the first case, is likely the default address (catch-all) setting for the domain. I suspect you have it set to forward all email to the account. A better option would be to set it to fail incoming messages at SMTP time.

    I hope this helps ;)
     
  3. xsenses

    xsenses Well-Known Member

    Joined:
    Aug 29, 2002
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Huntington Beach, Ca
    A little confused, I have the tweak settings set to Fail in WHM. I have no forwarders setup for the domain and see no way to delete the unrouted catch-all in cpanel. Thanks for the help.
     
  4. Stefaans

    Stefaans Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    451
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Vancouver, Canada
    The "catch-all" is the Default Address setting in cPanel.

    There was no such option in older versions of WHM. Accounts that you created before making this settings, may still have settings other than :fail:.
     
  5. xsenses

    xsenses Well-Known Member

    Joined:
    Aug 29, 2002
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Huntington Beach, Ca
    That is it. Thanks
     
    #5 xsenses, Jan 17, 2008
    Last edited: Jan 17, 2008
Loading...

Share This Page