The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

stoping followsymlinks give 500 internal error

Discussion in 'General Discussion' started by freakmedia, Aug 28, 2010.

  1. freakmedia

    freakmedia Registered

    Joined:
    Dec 18, 2009
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    hello
    i make this on my httpd.conf

    <Directory "/">
    Options ExecCGI -FollowSymLinks Includes IncludesNOEXEC Indexes -MultiViews +SymLinksIfOwnerMatch
    AllowOverride All
    </Directory>
    <Directory "/home">
    Options ExecCGI -FollowSymLinks -Includes IncludesNOEXEC Indexes -MultiViews SymLinksIfOwnerMatch
    AllowOverride AuthConfig Indexes Limit FileInfo Options=IncludesNOEXEC,Indexes,Includes,MultiViews,SymLinksIfOwnerMatch,DirectoryIndex,AddCharset,FileETag
    </Directory>

    but this htaccess not work

    DirectoryIndex kusaba.php
    AddCharset UTF-8 .html
    AddCharset UTF-8 .php
    FileETag None

    <IfModule mod_headers.c>
    <Files *.html>
    Header add Expires "Mon, 26 Jul 1997 05:00:00 GMT"
    Header add Pragma "no-cache"
    Header add Cache-Control "max-age=0; must-revalidate; no-cache"
    Header set Expires "0"
    Header unset Vary
    </Files>
    </IfModule>

    <Files spam.txt>
    order allow,deny
    deny from all
    </Files>
    # Warning: Contents below this line may be erased, please place all .htaccess rules above this line
    ## !KU_BANS:RewriteCond %{HTTP_REFERER} !^$

    the error log is .htaccess: Illegal option DirectoryIndex

    what can i do to fixed

    tnx
     
    #1 freakmedia, Aug 28, 2010
    Last edited: Aug 28, 2010
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You might try removing your changes you made from the httpd.conf and instead go to WHM > Service Configuration > Apache Configuration > and add those changes there by ticking boxes, instead. When you save this will distill and restart Apache for you so that those changes will be saved properly.

    More on working with Apache in cPanel here:
    Apache & cPanel/WHM
     

Share This Page