The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stopping exim-26?

Discussion in 'General Discussion' started by webignition, Feb 7, 2005.

  1. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    I recently enabled Exim on another port (port 26) for a client whose Internet provider was blocking port 25. My client is now able to send though his Internet provider and so no longer needs to send through Exim on port 26 on my server.

    Assuming that running Exim on port 26 as well means that there are two copies of Exim running, I decided to turn off Exim on port 26 so as to reduce the amount of memory being used.

    I went to WMH > Service Configuration > Service Manager and unchecked "exim on another port". I also then restarted Exim just to be on the safe side.

    When I now take a look at the service status, I see "exim-26" listed at the top which shows as being up and has a nice green icon indicating that all is OK. However I wouldn't expect this to be listed as I thought I'd turned it off.

    Could this be a bug in WHM or would this mean that Exim is still running on port 26 as well? When I telnet to my server on port 26 it does not accept any connection (the firewall is still letting through traffic on port 26 so that I can test this). This makes me think that Exim is not accepting connections on port 26.

    Any idea how I can:

    a) Get rid of "exim-26" from the service status?

    and

    b) Check if two copies of Exim are running?

    Thanks to anyone who can help!
     
  2. markhard

    markhard Well-Known Member

    Joined:
    Apr 22, 2004
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    16
    i having the same problem, exim 26 still listed on "Service Status".

    but actually exim on port 26 already turned off. you can check it several ways:

    1. telnet your server's port 26
    2. try send testing email using port 26
    3. ps aux | grep exim. i notice that exim port 26 have process name with "26" behind the word "exim" like /usr/sbin/exim [option] 26
     
  3. markhard

    markhard Well-Known Member

    Joined:
    Apr 22, 2004
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    16
    this is wierd.. after i upgrade to Cpanel 10.0.0-C82 i turn on exim on port 26 and then turn it off, but this time exim on port 26 didn't turned off as ps aux show /usr/sbin/exim -oX 26 -bd is running.

    is this a bug? just make me curious :confused:
     
    #3 markhard, Feb 15, 2005
    Last edited: Feb 15, 2005
Loading...

Share This Page