The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Strange Apache Issue

Discussion in 'EasyApache' started by johnyboy667, Jul 17, 2004.

  1. johnyboy667

    johnyboy667 Registered

    Dec 23, 2002
    Likes Received:
    Trophy Points:
    I did an update/rebuild to Apache in WHM under software because it said I was vulnerable on the WHM page, and now Apache won't start.

    I've executed these commands in shell and they give me this:

    root@host [~]# /usr/sbin/httpd configtest
    Warning: DocumentRoot [/dev/null] does not exist
    Syntax OK

    /dev/ exists when I ls to it, but not the null directory.

    I looked at the error log and SIGTERM appeared in it.

    I've tried graceful reboot, restart httpd, start httpd, doesn't work.

    On the WHM page it says:
    Unable to obtain apache version information. Your apache server at (serverip) may be down, or unreachable.

    (serverip not actual IP)

    And if I try to access the apache status under server information, it gives me the message,
    "Unable to retrieve apache status"

    Which I guess is a given since under service status it says apache is down and since it won't restart.

    BTW, I use Turck MMcache, does this need to be recompiled or something since I updated Apache? How would I do this?
    #1 johnyboy667, Jul 17, 2004
    Last edited: Jul 17, 2004
  2. Sinewy

    Sinewy Well-Known Member

    May 15, 2004
    Likes Received:
    Trophy Points:
    Sydney, Australia
    cPanel Access Level:
    DataCenter Provider
    comment it out in httpd.conf

Share This Page