dantium

Member
Nov 28, 2007
9
0
51
Something odd has occurred for no apparent reason and i can not work out whats going on, some help would be great.

Firstly i started getting some mysql errors, tables that crashed and need to be repaired, i resolved that by repairing the tables. Also I started getting errors in some PHP scripts trying to access different domains on the same server.

The main problem for now is the mail is not being forwarded for what it seems is all domains. I don't know if its some sort of DNS issue as the websites are working.

This is what i found in /usr/local/cpanel/logs/error_log

2009-02-23 06:09:57 info [cpsrvd] dig failed the usability test!

query failed: query timed out
2009-02-23 06:10:15 info [cpsrvd] /usr/local/cpanel/src/3rdparty/perl/perldig failed the usability test!

2009-02-23 06:10:15 warn [cpsrvd] No working dig found! at /usr/local/cpanel/Cpanel/DnsRoots.pm line 498
Cpanel::DnsRoots::_getdigutil() called at /usr/local/cpanel/Cpanel/DnsRoots.pm line 405
Cpanel::DnsRoots::_dig('cachetime', 30, 'nsips', ARRAY(0x834cea8), 'query', 'auth.cpanel.net') called at /usr/local/cpanel/Cpanel/DnsRoots.pm line 145
Cpanel::DnsRoots::_find_nameservers('auth.cpanel.net', 30, HASH(0x84b1554)) called at /usr/local/cpanel/Cpanel/DnsRoots.pm line 56
Cpanel::DnsRoots::fetchnameservers('auth.cpanel.net') called at /usr/local/cpanel/Cpanel/DnsRoots.pm line 341
Cpanel::DnsRoots::_resolveIpAddress('auth.cpanel.net') called at /usr/local/cpanel/Cpanel/CpKeyClt.pm line 160
eval {...} called at /usr/local/cpanel/Cpanel/CpKeyClt.pm line 142
Cpanel::CpKeyClt::cpkeyclt() called at perl/Cpanel/cpsrvd.so.pl line 37


Some help would be great, what can i do to resolve this problem?

Thanks

-Daniel
 

dantium

Member
Nov 28, 2007
9
0
51
Ok i checked the resolv.conf and the IPs in there stops being DNS servers for some reason so i changed the IPs to the 2 nameservers of the same machine and the mail is delivering ok now.

But still i have a PHP problem which would seem to be related to this:

getting some errors like this:

php_network_getaddresses: getaddrinfo failed: Name or service not known

Anyone have any ideas?
 

dantium

Member
Nov 28, 2007
9
0
51
resolved

OK this situation has resolved it self fully it would seem after i rebooted the server a few times. However i would like to double check, is it safe to have the resolver IPs (in the resolv.conf) point to the 2 NS IPs of the same machine?

-Dan
 

ItMan

Registered
May 24, 2008
1
0
51
Ok i checked the resolv.conf and the IPs in there stops being DNS servers for some reason so i changed the IPs to the 2 nameservers of the same machine and the mail is delivering ok now.

But still i have a PHP problem which would seem to be related to this:

getting some errors like this:

php_network_getaddresses: getaddrinfo failed: Name or service not known

Anyone have any ideas?
OS - FreeBSD 6.2 ?