Strange dovecot error from cron

Routes

Member
Aug 5, 2016
14
1
3
Austria
cPanel Access Level
Root Administrator
Hi,

I recently had a strange dovecot error mail from cron
I don't know what this is really about.
Can anybody help with it?

Thanks,
Tom

The header was :
/usr/bin/test -e /etc/cpanel-dovecot-solrdisable || /usr/local/cpanel/3rdparty/scripts/cpanel_dovecot_solr_commit

and the text :
Cpanel::Exception::HTTP::Network/(XID kp96ur) The system failed to send an <abbr title="Hypertext Transfer Protocol">HTTP</abbr> “GET” request to “http://J8kUiYWu7f57iRBd:[email protected]:8984/solr/dovecot/update?commmit=true” because of an error: Could not connect to '127.0.0.1:8984': Connection refused

at /usr/local/cpanel/Cpanel/Exception/CORE.pm line 330.
Cpanel::Exception::create("HTTP::Network", HASH(0xe20658)) called at /usr/local/cpanel/Cpanel/Exception.pm line 46
Cpanel::Exception::__ANON__(__CPANEL_HIDDEN__, HASH(0xe20658)) called at /usr/local/cpanel/Cpanel/HTTP/Client.pm line 102
Cpanel::HTTP::Client::request(Cpanel::HTTP::Client=HASH(0xa7af80), "GET", "http://J8kUiYWu7f57iRBd:__CPANEL_URLPW_HIDDEN__\@127.0.0.1:8984/solr/"..., HASH(0x138dac0)) called at (eval 5) line 6
HTTP::Tiny::get(Cpanel::HTTP::Client=HASH(0xa7af80), "http://J8kUiYWu7f57iRBd:__CPANEL_URLPW_HIDDEN__\@127.0.0.1:8984/solr/"...) called at /usr/local/cpanel/3rdparty/scripts/cpanel_dovecot_solr_commit line 55
scripts::cpanel_dovecot_solr_commit::run("scripts::cpanel_dovecot_solr_commit") called at /usr/local/cpanel/3rdparty/scripts/cpanel_dovecot_solr_commit line 37
 

Routes

Member
Aug 5, 2016
14
1
3
Austria
cPanel Access Level
Root Administrator
Hmm, thanks I know what solr is but I was/am not sure about this error. My cpanel install runs since January 2017 and this port was never open in csf/lfd and I never had any of these errors.
That is what's confusing me. And I also did not change my csf.conf since months for sure. It was just changed by csf updates but a diff is giving nothing on ports (as said this port was never open).
So why am I getting such an error now? Is solr itself trying to update something? Because the service itself never sent any of these mails and solr is also running since install.

I am always cautious if errors appear suddenly without system changes from myself.

Or was cpanel just updated to check on this and is now sending this error??
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,229
463
Hello,

Feel free to open a support ticket using the link in my signature if you'd like us to take a closer look to see why it's failing.

Thank you.