The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

strange mail receiving behavior for one account

Discussion in 'E-mail Discussions' started by elleryjh, Dec 28, 2005.

  1. elleryjh

    elleryjh Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    I've been using maildir for a while with no problems, but now this one user is experiencing problems with how his mail accounts work. I think he's been having the problem since conversion, he just hasn't pointed it out yet.

    Mail delivered to name1@domain.com and name2@domain.com are put into the directories /home/user/mail/domain.com/name1/.spam/ and /home/user/mail/domain.com/name2/.spam/ respectively, when they should be going into /home/user/mail/domain.com/name1/new/ and /home/user/mail/domain.com/name2/new

    Delivering to the .spam folder is not only the incorrect behavior, but makes it impossible to retreive the mail without first moving it to the inbox with FTP or SSH.

    Spam Assassin and spambox are both disabled on the account. There are no spam filters setup.

    If I create a new POP account with a different name, for example name3, it works correctly. However, if I delete name1, and create another pop account with the same name, name1, it will stil have the incorrect behavior.

    /var/log/exim_mainlog seems to be normal for the deliveries:
    2005-12-28 01:38:59 1ErUwe-0008De-Uw => user1 <user1@domain.com> R=virtual_user T=virtual_userdelivery


    The only workaround I can think of is it symlink new to .spam - not sure if it would work and even if it does, it's not the greatest solution.

    Anyone know why this might be happening? Thanks for any help.
     
Loading...

Share This Page