The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Strange problem sh: line 1:

Discussion in 'General Discussion' started by BuBa, Apr 13, 2006.

  1. BuBa

    BuBa Active Member

    Joined:
    Sep 25, 2002
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    The Netherlands
    I get this line now for a few days (every hour) and that user I don't have on my server anymore.

    This is what I get on my hourly check:

    sh: line 1: /home/somedo/public_html/forums/sources/action_public/misc/misc.php: No such file or directory

    in /var/spool/cron/ I don't have a cron with this line or what ever :rolleyes:

    Is there someone how know the solution or can give me a hint to get ride of this annoying line

    Regards,
    Martin
     
  2. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    If it's every hour, check in /etc/cron.hourly.
     
  3. BuBa

    BuBa Active Member

    Joined:
    Sep 25, 2002
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    The Netherlands
    Thanks for that suggestions, I have checked all the cron dirs and it don't exists..
    Are there more options to check?

    Regards,
    Martin
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Make doubly sure that it's not in a user cron:

    grep misc.php /var/spool/cron/*

    If not, then try restarting crond:

    service crond restart

    If it still continues, you'll need to check the cron log in /var/log/cron (usually) which should indicate what it is running and the username it is for.
     
  5. BuBa

    BuBa Active Member

    Joined:
    Sep 25, 2002
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    The Netherlands
    I did all you suggested:

    grep returns no response, so not found
    restarted crond, everything looks OK.

    No user have this, allmost all the crons are mine or not even come close to this line or user:

    sh: line 1: /home/betareso/public_html/forums/sources/action_public/misc/misc.php: No such file or directory

    Have a new one after restarting crond so I have now two problems :confused:
    sh: line 1: A?p: command not found

    Regards,
    Martin
     
Loading...

Share This Page