Strange problem with Apache and WHM...

DDJ

Registered
May 18, 2009
2
0
51
Hello, I have installed on my Dedicated Server an application which needs to listen on port 80 in order to work correctly.

To solve the obvious conflict with Apache which needs to listen on port 80 too, I modified the Apache configuration (from the "Tweak Settings" menu voice of the WHM panel where it says "The port on which Apache listens for HTTP connections") changing the default setting "0.0.0.0:80" (i.e. listen on "all IPs") with my main server IP "IP1:80". Then I modified my application to listen on the port 80 of the other IP address assigned to my server ("IP2:80").

Everything works fine but when I restart Apache from WHM I get this strange error "httpd has failed, please contact the sysadmin". Strange and misleading error because actually Apache starts fine and my site works perfectly. But because of this WHM error I can't monitor Apache from WHM anymore because it looks like "not started" (false!).

It seems that WHM doesn't like when you change the default Apache port for HTTP connections "0.0.0.0:80"...

Any help? Thank you!
Marco
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
Hello, I have installed on my Dedicated Server an application which needs to listen on port 80 in order to work correctly.

To solve the obvious conflict with Apache which needs to listen on port 80 too, I modified the Apache configuration (from the "Tweak Settings" menu voice of the WHM panel where it says "The port on which Apache listens for HTTP connections") changing the default setting "0.0.0.0:80" (i.e. listen on "all IPs") with my main server IP "IP1:80". Then I modified my application to listen on the port 80 of the other IP address assigned to my server ("IP2:80").

Everything works fine but when I restart Apache from WHM I get this strange error "httpd has failed, please contact the sysadmin". Strange and misleading error because actually Apache starts fine and my site works perfectly. But because of this WHM error I can't monitor Apache from WHM anymore because it looks like "not started" (false!).

It seems that WHM doesn't like when you change the default Apache port for HTTP connections "0.0.0.0:80"...

Any help? Thank you!
Marco
At this time, chkservd (which checks for services being online) is unaware of any changes made to the Apache Port in WHM. This is a known issue but I have no ETA on when this will be resolved. (Internal Case: 26350)
 

PlatinumServerM

Well-Known Member
PartnerNOC
Jul 10, 2005
400
3
168
New Jersey, USA
cPanel Access Level
Root Administrator

Infopro

Well-Known Member
May 20, 2003
17,076
524
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
Important cPanel/WHM Version Number Designation Change

Please Note: Important cPanel/WHM Version Number Designation Change

As of July 28, 2010 the cPanel/WHM version number designations have been officially changed.

Version 11.25.1 is now designated 11.28 and version 11.25.2 is now designated 11.30.

These new changes were explained in some detail recently at the July 2010 - Quarterly Road map - Webinar direct from cPanel's PodCast Studio in Houston, Texas with speakers David Grega and Mario Rodriguez.

An official press release about these changes is forthcoming and can be accessed at this link as soon as it's made available to the Forum Team:
Important cPanel/WHM Version Number Designation Change (To be updated)

This post serves to update users who are subscribed to threads (where this message is posted) looking forward to upcoming enhancements in future versions of cPanel.