The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

strange proftpd problem

Discussion in 'General Discussion' started by uadm, Aug 23, 2003.

  1. uadm

    uadm Well-Known Member

    Joined:
    May 19, 2003
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    Howdy

    We're experiencing strange proftpd delays at login time. the login procedure just hangs for about 15-20 seconds before the prompt.
    What is even stranger is that if we change from proftpd to pure-ftpd and back, the delay is gone, untill the first time proftpd is startd manualy with: service proftpd stop/start. then the delay is back

    Any idea what that could be?

    Thanks
     
  2. www-lab

    www-lab Well-Known Member

    Joined:
    Feb 1, 2003
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    I have the same problem :(

    cPanel.net Support Ticket Number:
     
  3. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
  4. uadm

    uadm Well-Known Member

    Joined:
    May 19, 2003
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    I've read it all. there's nothing that talk about my (cpanel's) problem there.

    cPanel.net Support Ticket Number:
     
  5. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Solution to the problem

    Here is what I found to be the solution to the problem. I edited the /etc/proftpd.conf file and added "IdentLookups off" toward the top of the conf file, like this:

    ServerName "ProFTPD"
    AuthUserFile /etc/proftpd/passwd.vhosts
    LogFormat BytesLog "%b"
    ServerType standalone
    DeferWelcome on
    DefaultServer on
    DefaultRoot ~ !wheel
    IdentLookups off

    At first, it didn't work because I was restarting ProFTPd using the restart services link in WHM. Finally, I realized that I needed to restart from the command line, and THEN it started working:

    /etc/rc.d/init.d/proftpd stop
    /etc/rc.d/init.d/proftpd start

    I hope this helps!

    - Scott
     
Loading...

Share This Page