The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Strange SpamAssassin/filtering issue

Discussion in 'E-mail Discussions' started by TerryW, Mar 5, 2014.

  1. TerryW

    TerryW Registered

    Joined:
    Mar 5, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello.

    We have a server in the office that is running cPanel and has a large number of domains on it. I am having a weird problem with spam filtering and need some assistance, please.

    (Bear in mind the following domain names are made-up for privacy reasons)

    When anyone from senderdomain.com sends to certain domains on our server, it ends up in spam. With other domains, it goes to the inbox as it should.

    person@senderdomain.com wasn't getting through to person@recipientdomain1.com or person@recipientdomain2.com even though I had specfically whitelisted the email address and the entire domain in SpamAssassin. Still goes to the spam folder. I then created a temporary email address on another domain on the same hosting server, test@mailworkshere.com

    When sending the exact same email from person@senderdomain.com to the above addresses, it goes to spam on the recipientdomain1.com and recipientdomain2.com accounts, but goes to the inbox on mailworkshere.com even though on all three domains the email is not flagged as spam.

    Please see below mail headers, I had person@senderdomain.com send one email to the three above recipient addresses. As I said before, with test@recipientdomain1.com and test@recipientdomain2.com the email ends up in the spam folder even though person@senderdomain.com and *@senderdomain.com are whitelisted and the spam score is good. test@mailworkshere.com receives the same email in the inbox as it should.

    I cannot fathom why this is happening, and what I can do to get mail from person@senderdomain.com to not end up in the spam folder.

    I have included mail headers from an email sent to all three addresses, can somebody assist me with this please? I'm hoping there is something obvious and stupid I have overlooked that would be causing this.

    Thanks!



    ---



    Code:
    Return-path: <person@senderdomain.com>
    Envelope-to: test@recipientdomain1.com
    Delivery-date: Tue, 04 Mar 2014 18:06:53 +0200
    Received: from smtp.server.com ([ip.add.res.s]:2664)
    by hostingserver.com with esmtp (Exim 4.82)
    (envelope-from <person@senderdomain.com>)
    id 1WKrri-0001Ew-22
    for test@recipientdomain2.com; Tue, 04 Mar 2014 18:06:53 +0200
    Received: from unix-01.senderdomain.com (Not Verified[ip.add.res.s]) by smtp.server.com with MailMarshal (v7,1,2,5898) (using TLS: SSLv23)
    id <B5315fa130000>; Tue, 04 Mar 2014 18:06:43 +0200
    Received: from nt-01.senderdomain.local (nt-01.senderdomain.com [192.168.0.2])
    by unix-01.senderdomain.com (8.13.1/8.13.1) with ESMTP id s24G6Qqj014551
    for <test@recipientdomain1.com>; Tue, 4 Mar 2014 18:06:27 +0200
    Content-class: urn:content-classes:message
    Return-Receipt-To: "The Sender" <person@senderdomain.com>
    MIME-Version: 1.0
    Content-Type: multipart/mixed;
    boundary="----_=_NextPart_001_01CF37C3.B1E64D6A"
    Disposition-Notification-To: "The Sender" <person@senderdomain.com>
    Subject: FW: Email delivery issue
    X-MimeOLE: Produced By Microsoft Exchange V6.5
    Date: Tue, 4 Mar 2014 18:04:12 +0200
    Message-ID: <2DC6BCDC7BBF7243B0A97608E4BD6B02023E69AB@nt-01.senderdomain.local>
    In-Reply-To: <5315F42A.9060909@hostingserver.com>
    X-MS-Has-Attach: yes
    X-MS-TNEF-Correlator:
    Thread-Topic: Email delivery issue
    Thread-Index: Ac83wEHRDq+FMzOjTFiCk531S2+8GgAAtyVA
    References: <5315F42A.9060909@hostingserver.com>
    From: "The Sender" <person@senderdomain.com>
    To: <test@recipientdomain1.com>, <test@recipientdomain2.com>, <test@mailworkshere.com>,
    <myself@hostingserver.com>
    X-Virus-Scanned: clamav-milter 0.96.2 at unix-01.senderdomain.com
    X-Virus-Status: Clean
    X-Spam-Flag: YES
    X-Spam-Status: Yes, score=6.5 required=5.0 tests=ALL_TRUSTED,AWL,BAYES_99,
    FH_DATE_PAST_20XX,HTML_MESSAGE autolearn=no version=3.2.4
    X-Spam-Level: ******
    X-Spam-Checker-Version: SpamAssassin 3.2.4 (2008-01-01) on unix-01.senderdomain.com
    X-Spam-Status: No, score=-2.6
    X-Spam-Score: -25
    X-Spam-Bar: --
    X-Ham-Report: Spam detection software, running on the system "hostingserver.com", has
    identified this incoming email as possible spam. The original message
    has been attached to this so you can view it (if it isn't spam) or label
    similar future email. If you have any questions, see
    root\@localhost for details.
    
    Content preview: Hi there, Herewith TEST Mail as requested! Kindly confirm
    well received. [...]
    
    Content analysis details: (-2.6 points, 7.0 required)
    
    pts rule name description
    ---- ---------------------- --------------------------------------------------
    -0.7 RCVD_IN_DNSWL_LOW RBL: Sender listed at dnswl.org - Protect against false positives, low
    trust
    [81.94.204.147 listed in list.dnswl.org]
    -1.9 BAYES_00 BODY: Bayes spam probability is 0 to 1%
    [score: 0.0000]
    0.0 HTML_MESSAGE BODY: HTML included in message
    X-Spam-Flag: NO 
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The message logs you provide indicate the message was not detected as SPAM. Could you open a support ticket using the link in my signature so we can attempt to reproduce this issue or further review the mail logs to determine why emails are placed in the "SPAM" folder when SpamAssassin does not detect them as SPAM? Please post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  3. TerryW

    TerryW Registered

    Joined:
    Mar 5, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi Michael,

    Thank you for your response! I have opened a ticket as you requested, my ticket number is 4632417

    Please do not hesitate to contact me or reply to this post should you require any more information or mail logs, as I will be happy to provide these.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    We sent a reply to the ticket requesting more information, but we have not heard back from you yet. Feel free to reply to the ticket with that information at your earliest convenience.

    Thank you.
     
Loading...

Share This Page