The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Strange SSL Problem

Discussion in 'General Discussion' started by celliott, May 3, 2006.

  1. celliott

    celliott Well-Known Member

    Joined:
    Jan 2, 2006
    Messages:
    460
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    United Kingdom
    I have just setup SSL for one of our clients using a Dedicated IP etc as usual and a Certificate from Namecheap.

    When accessing via https:// I get the following:

    [​IMG]

    The page also seems to be refreshing constantly, since that window is flickering. I can click Yes and No on that window constantly holding down the enter key, and nothing happens at all.

    I have checked the SSL Certificate and the Domain information is correct, having installed SSL on other servers in the past.

    I am running the latest cPanel-Current build. Recompiling apache with current settings didnt do anything either.

    Anyone have any ideas?

    Thanks,

    Chris
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Did you upload the cert and key in ASCII/TXT mode? If yes, make sure there are no weird characters or carriage returns in the both files. Are they using Global Root CA file? If yes, make sure it is installed and add a directive in the httpd.conf file. Does this happened with every PC you use to access this site securely?

    In any case, the last resort is send an email note to the cert issuing company and see if they have any problem with the cert generated for you.
     
  3. celliott

    celliott Well-Known Member

    Joined:
    Jan 2, 2006
    Messages:
    460
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    United Kingdom
    Just noticed that theres yet another cPanel update on the current tree; there has been at least 4 in the last few days :eek:

    An upgrade to Current-56 has fixed the problem.

    Thanks for your suggestion though :)
     
  4. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    That's very interesting ;)
     
  5. celliott

    celliott Well-Known Member

    Joined:
    Jan 2, 2006
    Messages:
    460
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    United Kingdom
    I spoke too soon, its still there. I checked the certificate and its definatley correct :(
     
Loading...

Share This Page