The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

struggling to send email via isp

Discussion in 'E-mail Discussions' started by keat63, Jun 23, 2015.

  1. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    765
    Likes Received:
    20
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    If i try to send email via an account on my server, from my phone, using my home internet connection, i'm getting sending failed.
    If i send via carrier 3g, it sends OK.
    (so it's not account related)

    I've checked CSF and the IP is allowed, its also white listed in Host Access control as well as CPHulk.
    I can send from my PC via the same ISP.
    (so it's not IP blocking related)

    If I come to work, then i can send emails from my phone using my work ISP.
    (so not phone related)

    I am well and truly baffled to say the least.

    Any pointers would be gratefully received.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,472
    Likes Received:
    200
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    What port is mail on, on your phone?

    Most ISPs block port 25 these days.
     
  3. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    765
    Likes Received:
    20
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    It is on port 25, but this wouldn't explain why my PC could connect, unless of course my PC is configured for a different port and it just so happens to be working.
    I've been scouring the logs this morning and can see no effort of my phone trying to connect until i went 4g, so maybe port 25 is being blocked by my ISP.
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,472
    Likes Received:
    200
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    In:
    Home »Service Configuration »Service Manager, Exim Mail Server (on another port)

    Do you have another port added here? For example, 587.
     
  5. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    765
    Likes Received:
    20
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    no.
    port 26 is listed but both radio buttons are disabled.

    I've done a quick google search for port 25 blocking, naming my ISP and this is what came up.

    “The only restriction we’ve put in place is an email setting that helps protect our customers against unsolicited emails, also known as spam. (For the techies amongst you we stop connections to non-EE SMTP servers on port 25, and block NetBIOS”

    So maybe the outlook client on my PC is configured to send on a different port to 25.
    However, if it is then i'm equally as confused as to how it's being sent unless whitelisting is allowing this.
     
    #5 keat63, Jun 23, 2015
    Last edited: Jun 23, 2015
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,472
    Likes Received:
    200
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Interesting. I wonder why both are disabled?

    Both should be enabled, and you can use 26, or 587. Be sure to open the same port in your firewall as well.

    Login to cPanel > Mail section > Accounts, scroll down to find your email address listed.
    On right side, select the More menu > Configure Mail Client.

    There, in the Non-SSL Settings you should see port 587 (or 26, depending on which you used) listed for Outgoing mail server setting. Change that on your phone, and every other device that connects to mail.

    You may be blocked if your IP is not whitelisted in advance in cPHulk and CSF and you try to connect to the server using the old settings of course. ;)

    HTH!
     
  7. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    765
    Likes Received:
    20
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    I've added port 26 as you've suggested and modified my phone to suit.
    Lets see how it works tonight when i get home.

    also need to check what port my PC is configured for.
     
  8. rackaid

    rackaid Active Member

    Joined:
    Jan 18, 2003
    Messages:
    42
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Jacksonville, FL
    cPanel Access Level:
    DataCenter Provider
    I recommend using port 587. Port 587 is reserved for email submission. Port 26 is unassigned. I've seen more and more ISPs also block port 26 as well.
     
    Infopro likes this.
  9. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    765
    Likes Received:
    20
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Well it does seem that port 25 was the issue, as email worked on port 26.
    I checked the config on my PC and found this was configured for 587.

    So now what i don't get, if "Exim Mail Server (on another port)" was unchecked and doesn't have port 587 applied, how come email works on port 587.
    587 is open in CSF though.
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,852
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Exim listens on port 587 by default:

    # netstat -lnp | grep :587
    tcp 0 0 0.0.0.0:587 0.0.0.0:* LISTEN 12383/exim
    tcp6 0 0 :::587 :::* LISTEN 12383/exim

    Thank you.
     
Loading...

Share This Page