Stuck trying to upgrade to 4.3.8

luis

Well-Known Member
Sep 3, 2001
50
0
306
These are the last few lines of a /scripts/easyapache option 5

Code:
00:20:59 URL:http://layer1.cpanel.net/buildapache/1/libmcrypt-2.5.7.tar.gz [523321/523321] -> "libmcrypt-2.5.7.tar.gz" [1]
Untarring mcryptDone
configure libmcrypt-2.5.7...(--prefix=/usr --disable-posix-threads)..................Done
make libmcrypt-2.5.7...............................................Done
make libmcrypt-2.5.7...(install)....Done
00:22:03 URL:http://layer1.cpanel.net/buildapache/1/php-4.3.8.tar.gz [5178420/5178420] -> "php-4.3.8.tar.gz" [1]
Untarring php....Done
Applying GD FT_ENCODING_MS_SYMBOL patch
patching file ext/gd/libgd/gdft.c
Applying CURL curl_formfree patch
patching file ext/curl/curl.c
configure php-4.3.8...(--with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-mcrypt --enable-magic-quotes --with-mysql --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --with-freetype-dir=/usr --enable-gd-native-ttf --enable-versioning --with-zlib)...............................................................................Done
make php-4.3.8...(clean)....Done
make php-4.3.8........................................................Done
make: *** [ext/gd/libgd/gdft.lo] Error 1
make php-4.3.8...(install)....Done
make: *** [ext/gd/libgd/gdft.lo] Error 1
configure php-4.3.8...(--prefix=/usr --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-mcrypt --enable-magic-quotes --with-mysql --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --with-freetype-dir=/usr --enable-gd-native-ttf --enable-versioning --with-zlib)..........................................................................Done
make php-4.3.8...(clean)....Done
make php-4.3.8........................................................Done
make: *** [ext/gd/libgd/gdft.lo] Error 1
make php-4.3.8...(install)....Done
make: *** [ext/gd/libgd/gdft.lo] Error 1
x - creating lock directory
x - extracting /usr/local/frontpage/version5.0/apache-fp/fpexe.c (text)
x - creating lock directory
x - extracting /usr/local/frontpage/version5.0/apache-fp/fpexe3-suexec.patch (text)
patching file fpexe.c
Using Frontpage Passthough with suexec
./build all
./build install
Waiting for httpd to restart..............finished.

root      2857  6.1  1.0 12652 7776 ?        S    00:26   0:00 /usr/local/apache/bin/httpd -DSSL

httpd started ok
./build install
Waiting for httpd to restart..............finished.

root      2931  6.6  1.0 12652 7776 ?        S    00:26   0:00 /usr/local/apache/bin/httpd -DSSL

httpd started ok

Any clues?
 

luis

Well-Known Member
Sep 3, 2001
50
0
306
Thanks for the response OCX...
Where do i install GD within WHM?

I went to "Install an RPM" within WHM but GD is not on the list....

Thanks in advance :)