The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

stunnel issues are upcp to 11.18.3-CURRENT_23567

Discussion in 'General Discussion' started by nyjimbo, Apr 19, 2008.

  1. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    On two of our freebsd 6.2 boxes after running WHM "uprade to latest" and it installing 11.18.3-CURRENT_23567 we found "stunnel" using up to 70% of cpu and spewing errors about reading /etc/hosts.allow

    We had to kill it and restart is with 'stopstunnel' & 'startstunnel', however when we booted one of the boxes we noticed that stunnel now did not come up on its own and had to be "startstunnel" to get it going.

    Anyone else see this problem ?
     
  2. cgotstein

    cgotstein Registered

    Joined:
    May 10, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    yes, same issue here. Can't get into webhost manager anymore and stunnel taking up resources. running freebsd 5.4, ran update on current yesterday. need help!
     
  3. Eric Martello

    Eric Martello Member

    Joined:
    Dec 30, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    After doing a /scripts/upcp --force to fix an IMAP login issue, I am now unable to access WHM or CPANEL on any of the domains. I use version 11.13.3-RELEASE. No error messages in log files, but I do get a cpsrvd failed email every few minutes....
     
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    stunnel should only start as a fallback (unless you have it enabled) when native ssl support fails to install. Please open a ticket to my attention so we can determine why the native ssl installer is failing on your machine.

    https://tickets.cpanel.net/submit/
     
  5. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    Ok, will do. We have nativessl ticked in the tweak settings. I was babysitting the boxes and just now one of them went nuts after the upcp at 1:45am, even though its set to 'manual update' for everything it still tried to do something and stunnel began to eat the cpu. I'll open a ticket in the AM. thanks.
     
  6. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    I take it back, both boxes did the same thing. The other one did it at 2:10am (the time of its upcp cycle). :eek:
     
  7. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
  8. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York

    Ok, I just did this on our other freebsd box and it appeared to install ok, but I still saw stunnel running.

    I killed stunnel, but now I dont get to ssl via https://www.domain.com:2087

    Did I skip something or is there something else that needs to be done?

    Thanks !
     
  9. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Sorry, restarting was subconscious for me so I failed to post it:


    /usr/local/cpanel/startup

    Previous post amended
     
  10. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    thanks, I JUST did it now before I read this. It should have been obvious to me too. :eek:
     
Loading...

Share This Page