SamSpade

Member
May 18, 2013
7
0
1
cPanel Access Level
Root Administrator
Through logwatch I received the following notification:

Stunnel
**Unmatched Entries**
(1) LOG5[2313:140319341717440]: stunnel 4.29 on x86_64-redhat-linux-gnu with OpenSSL 1.0.0-fips 29 Mar 2010
(1) LOG5[2313:140319341717440]: Threading:PTHREAD SSL:ENGINE Sockets:POLL,IPv6 Auth:LIBWRAP
(1) LOG5[2313:140319341717440]: 500 clients allowed
(1) LOG3[2313:140319341717440]: Error binding cpanelhttps to 0.0.0.0:2083
(1) LOG3[2313:140319341717440]: bind: Address already in use (98)
(1) LOG5[2304:140117113300928]: stunnel 4.29 on x86_64-redhat-linux-gnu with OpenSSL 1.0.0-fips 29 Mar 2010
(1) LOG5[2304:140117113300928]: Threading:PTHREAD SSL:ENGINE Sockets:POLL,IPv6 Auth:LIBWRAP
(1) LOG5[2304:140117113300928]: 500 clients allowed
(1) LOG3[2304:140117113300928]: Error binding cpanelhttps to 0.0.0.0:2083
(1) LOG3[2304:140117113300928]: bind: Address already in use (98)
In addition while restarting Cpanel I constantly get

Starting cPanel ssl services: Waiting for (?^:^(?:stunnel$|stunnel-[0-9\.]+local)) to shutdown ... not running. [FAILED]
I am running Cpanel current version.

I tried several solutions proposed in this forum and other forums but I finally couldn't figure out the problem.

Do you have any ideas how to solve this?

Greetings
SamSpade
 
Last edited:

SamSpade

Member
May 18, 2013
7
0
1
cPanel Access Level
Root Administrator
Starting cPanel ssl services: Waiting for (?^:^(?:stunnel$|stunnel-[0-9\.]+local)) to shutdown ... not running. [FAILED]

This is "normal" (although somewhat misleading due to "[Failed]" statement) as stunnel is deactivated by a setting in WHM Tweak Settings "SSL Support for cPanel daemons (no stunnel)=yes". When switching it to off, the "error message" disappears.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

Yes, that message will appear while restarting cPanel when "SSL Support for cPanel daemons (no stunnel)" is enabled in "WHM Home » Server Configuration » Tweak Settings". It happens because stunnel is not enabled, thus an attempt to stop it will fail. It's not recommended that you disable this option in "Tweak Settings". Instead, you can safely ignore the "Failed" statement when restarting cPanel.

Thank you.