The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sub domain not working?

Discussion in 'General Discussion' started by lblanchardiii, Sep 27, 2009.

  1. lblanchardiii

    lblanchardiii Well-Known Member

    Joined:
    Nov 20, 2005
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    I setup a domain name in my WHM, ut2004.ut-files.com but it's not working. The domain doesn't resolve. Usually when I setup sub domains they resolve instantly, but this time it's not.

    ut-files.com resolves to the same server
    forums.ut-files.com, news.ut-files.com (resolved as soon as I setup the accounts last month)

    I can go to the ip:username to get to the site, but the actual url wont.
     
  2. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    There could be a lot of reasons for this and I couldn't tell you for sure without taking a look at your server and your configurations.

    However, the first place I would look is the DNS zone file for your domain located on the system as /var/named/(your domain).db

    Second thing I would examine is any .htaccess files anywhere in the account or folders above it and note in particular and mod_rewrite commands within those .htaccess file(s).
     
  3. lblanchardiii

    lblanchardiii Well-Known Member

    Joined:
    Nov 20, 2005
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    I removed all the .htaccess files (was only one) still same result.

    Here is a copy of my zone record.

    Code:
    ; cPanel 11.24.5-RELEASE_38506
    ; Zone file for ut2004.ut-files.com
    $TTL 14400
    @      86400    IN      SOA     ns1.skyhighhosting.com. blah.gmail.com. (
                    2009092702      ; serial, todays date+todays
                    86400           ; refresh, seconds
                    7200            ; retry, seconds
                    3600000         ; expire, seconds
                    86400 )         ; minimum, seconds
    
    ut2004.ut-files.com. 86400 IN NS ns1.skyhighhosting.com.
    ut2004.ut-files.com. 86400 IN NS ns2.skyhighhosting.com.
    ut2004.ut-files.com. 86400 IN NS ns3.skyhighhosting.com.
    ut2004.ut-files.com. 86400 IN NS ns4.skyhighhosting.com.
    
    
    ut2004.ut-files.com. IN A 64.34.170.212
    
    localhost.ut2004.ut-files.com. IN A 127.0.0.1
    
    ut2004.ut-files.com. IN MX 0 ut2004.ut-files.com.
    
    mail IN CNAME ut2004.ut-files.com.
    www IN CNAME ut2004.ut-files.com.
    ftp IN A 64.34.170.212
    cpanel IN A 64.34.170.212
    whm IN A 64.34.170.212
    webmail IN A 64.34.170.212
    webdisk IN A 64.34.170.212
    
     
  4. lblanchardiii

    lblanchardiii Well-Known Member

    Joined:
    Nov 20, 2005
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    Apparently this time it did need time to resolve.

    I checked it again a day later and it works fine now.
     
Loading...

Share This Page