The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Subdomain and redirects not working

Discussion in 'General Discussion' started by TheBee, Dec 31, 2004.

  1. TheBee

    TheBee Member

    Joined:
    Nov 27, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Issue 1:
    I have created a webmail.domain.ext subdomain and redirected it to https://mail.domain.ext:2096. mail.domain.ext is an A record pointing to correct IP.

    If I goto to https://mail.domain.ext:2096 in browser all works perfectly--able to login to webmail. However, the webmail redirection doesn't work. DNS indeed has record for webmail.domain.ext.

    What is the problem and how do I correct? This is a problem for all addon domains and the primary domain.

    Issue 2:
    I have one addon domain. Domain1 is my primary domain. Domain2 is my addon domain. I have created a webmail.domain1.ext subdomain and redirected it to https://mail.domain1.ext:2096. When I create a webmail.domain2.ext subdomain and specify https://mail.domain2.ext:2096 for redirection, cpanel replaces https://mail.domain2.ext:2096 in all of my redirects. If I go to another redirect, say webmail.domain1.ext and specify https://mail.domain1.ext:2096 (what it was before I set redirect for webmail.domain2.ext) for redirect all other redirects get this. Why is cpanel setting redirect I specify for one subdomain for all subdomains? This shouldn't be. With this I can only have one subdomain redirect per account. :( :(

    I appreciate anyones help with these issues.

    Thank you and happy new year.
     
Loading...

Share This Page