The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

subdomain errors on domain with hyphen

Discussion in 'General Discussion' started by toykilla, Dec 7, 2007.

  1. toykilla

    toykilla Registered

    Joined:
    Nov 14, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    When I try to use subdomains on my hyphened top level domain I just get 403 Forbidden errors. These work fine on my other Plesk server. Is this a known bug? How can I fix this?

    Example:
    sub.domain.com WORKS
    sub.my-domain.com DOES NOT WORK.
     
  2. David Copeland

    Joined:
    Jun 30, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Has this been resolved?
     
  3. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    I can confirm that weve had a customer reporting this problem today.

    However, I logged into their cpanel via WHM and created a sub domain fine. I then logged in to cpanel as the customer using their login details and again managed to create a subdomain without any problem at all.

    EDIT: Sorry - I made a mistake here.

    The customer complains that they get a 403 on trying to view the subdomain after it has been created. I thought the customer was complaining that when they attempt to create the subdomain the error happens then.

    This is just indexing. If there is nothing in the folder - it will display a 403 unless you switch on standard indexing.

    Although we have standard indexing on by default so when we create main accounts, they display "index of". It seems that when creating sub domains only for main domains containing a hyphen cpanel is ignoring the default indexing and switching indexing off.

    On the same server I created a sub domain on a domain that did not contain a hyphen and the standard indexing was in place.
     
    #3 4u123, Aug 21, 2008
    Last edited: Aug 21, 2008
  4. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    Ok,

    Further investigation shows that hyphens are nothing to do with this at all - its just a coincidence that the original poster had a hyphen and so did my customer today.

    The indexing is inherited from the main htaccess file in the public_html directory becasue, by default, a folder for a subdomain does not contain an htaccess file at all so it will simply inherit the indexing from its parent folder.

    This customer is using a joomla site with a packaged htaccess file containig the line "Options -Indexes" to disable indexing which is why his subdomains also have no indexing.
     
Loading...

Share This Page