The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Subdomain mixing accounts

Discussion in 'General Discussion' started by cmnb, May 12, 2016.

  1. cmnb

    cmnb Registered

    Joined:
    May 12, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Mexico
    cPanel Access Level:
    Root Administrator
    Hi,

    I have a strange problem which I don't know what can be the cause.
    I have a VPS with several accounts, when one of the accounts -I will call it account1- creates a subdomain, for example subdomain1.account1.com, the content of subdomain1.account1.com appears the same as the content of the subdomain in other account -I will call it account2-.
    So the content of subdomain1.account1.com is the same of anothersubdomain.account2.com
    No matter how many subdomains I create on account1.com all get the content of anothersubdomain.account2.com

    Both accounts does not have anything in common (except for beeing on the same VPS), they have different names and are on different folders, so I don't know what to do.

    Hope someone can help me.
    Thank you.
     
  2. LostNerd

    LostNerd Well-Known Member

    Joined:
    Mar 12, 2014
    Messages:
    258
    Likes Received:
    11
    Trophy Points:
    18
    Location:
    Hastings, East Sussex, UK
    cPanel Access Level:
    Root Administrator
    Twitter:
    This is very strange behavior. If I have interpreted this post correctly, subdomains from account1 are showing data from account2. If this is the case, I suggest submitting a ticket to cPanel so that they may investigate further.
     
  3. cmnb

    cmnb Registered

    Joined:
    May 12, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Mexico
    cPanel Access Level:
    Root Administrator
    I believe the problem is when I try to load a site (domain or subdomain) via https that doesn't have a SSL certificate installed.
    If https://site1.com does not have a SSL certificate it loads the content of site2.com that does have a SSL certificate and it is the primary site for the IP adress on the server.
    I don't know if this is the intended behaviour or it is some kind of bug.
     
  4. cPTerrance

    cPTerrance *nix Technical Analyst II / Migrations Specialist
    Staff Member

    Joined:
    Jul 9, 2015
    Messages:
    72
    Likes Received:
    8
    Trophy Points:
    8
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    This is absolutely intended behavior, if you have three sites on a Shared IP Address and 1 out of the 3 sites has an SSL Certificate and the other 2 do not, they will redirect to the site that has the SSL Certificate if https/443 is used.
     
    cmnb likes this.
Loading...

Share This Page