The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

subdomain not working

Discussion in 'General Discussion' started by sitedev.li, Feb 25, 2014.

  1. sitedev.li

    sitedev.li Registered

    Joined:
    Feb 25, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    We can not access subdomain created by cpanel from ten days ago. IE show that "This page can’t be displayed“.

    The main domain of the subdomain is hosted on a dedicated server in Hetzner Online AG with local name server and work well.

    The www. mydomain, ftp.mydomain can be accessed.

    I looked in the DNS from WHM and the subdomain is added right, and DNS is all right as normal.

    Subdomain folder is created inside the public_html with 755, correct owner, etc;

    I cleared the browser cache on my machine;

    I have read all related posts in the forum, and no one can fix my problem.
     
  2. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    The DNS may show correct from WHM, but is this server acting as your nameserver as well, or is it clustered to another nameserver? It's hard to see without being able to run some tests against your domain, so if you want some assistance on this you can PM me your subdomain and I'll take a look. Or contact your hosting provider.
     
  3. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    Just curious if you restart Apache after adding?
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    651
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Check to see if the primary domain associated with the subdomain uses the domain registrar name servers or has it's DNS handled on remote name servers. If it does, then ensure you add the "A" record for the subdomain at that DNS provider.

    Thank you.
     
    rhenderson likes this.
Loading...

Share This Page