The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Subdomain Remote Mailserver setup

Discussion in 'E-mail Discussions' started by Snowman30, Nov 22, 2005.

  1. Snowman30

    Snowman30 Well-Known Member
    PartnerNOC

    Joined:
    Apr 7, 2002
    Messages:
    681
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    Got a bit of a weird issue with a site which has one of its subdomains needsing its MX record pointed to another server.

    I have the subdomain setup as an A record pointing to the remote IP and it works fine

    However ive setup an MX record for the subdomain to point to it as well and it wont work..

    ie:

    subdomain 14400 IN A xxx.xxx.xxx.xxx
    subdomain 14400 MX 0 subdomain.domain.com.


    web requests go thru to the remote server at xxx.xxx.xxx.xxx without any issue but mail doesnt.

    The subdomain is setup in the remote domains file and the main domains mail is working normally.

    Ive tried to test the email on the subdomain using dnsreport.com and i get either an error showing No IP address or the MX is showing:

    subdomain.domain.com.domain.com.

    anyone have any ideas on whats going on here?
     
  2. fikse

    fikse Well-Known Member

    Joined:
    May 10, 2003
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    16
    have you checked to make sure it's not listed in the /etc/localdomains file?
     
Loading...

Share This Page