tryingwebman

Well-Known Member
Sep 27, 2015
57
0
6
UK
cPanel Access Level
Root Administrator
NOTE: I MENT ADDON DOMAIN NOT SUBDOMAIN

Hi all,

I recently decided to set one of my addon domain sites to its own IP address the steps i have taken so far are as follows...

Requested IPs from my provider these were added to my account.

After reading documentation i decided the best way to achieve what i want was to create a new cPanel account for the domain so i..

Deleted the subdomain from the main account.

Created a new cPanel account for the domain ticking assign its own IP.

I restored the backup of the site but i cannot access anything i get the Sorry page for main domain and

The server can not find the requested page:

domain.com/admin (port 80)

for admin access. I have tried this with fresh CMS install and get the same results.

Have i overlooked anything. I have rebuilt apache, reset DNS zone for the domain and performed a graceful reboot but still no joy.

I know i have probably overlooked something silly/simple any help would be much appreciated.

Thanks
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Hello :)

You can try rebuilding the Apache configuration file via:

Code:
/scripts/rebuildhttpdconf
Also, check to ensure the domain name resolves to the same IP address that it's assigned in Web Host Manager.

Thank you.
 

tryingwebman

Well-Known Member
Sep 27, 2015
57
0
6
UK
cPanel Access Level
Root Administrator
Hello :)

You can try rebuilding the Apache configuration file via:

Code:
/scripts/rebuildhttpdconf
Also, check to ensure the domain name resolves to the same IP address that it's assigned in Web Host Manager.

Thank you.
Hi Micheal,

I have already done this from reading other answers by you in other thread.

No joy.

It seams it is actually resolving to the IP address of my NS1.

The only place this ip address is in the domains DNS is in the SPF record is this incorrect?

I really want to get my site back online your help is greatly appreciated.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Have you reviewed a website such as IntoDNS to verify your domain name uses the correct name servers? It seems like this is either a DNS cache issue, or an issue where the DNS for the domain name is handled by a third-party and thus the "A" record is not updated.

Thank you.
 

tryingwebman

Well-Known Member
Sep 27, 2015
57
0
6
UK
cPanel Access Level
Root Administrator
Have you reviewed a website such as IntoDNS to verify your domain name uses the correct name servers? It seems like this is either a DNS cache issue, or an issue where the DNS for the domain name is handled by a third-party and thus the "A" record is not updated.

Thank you.
The name servers reported by intodns are those of CloudFlare. I have paused the site on my cloudflare account while doing this. I figured possibly noobishly that the name servers are staying the same so it won't matter i planned to just resume them once i had moved the site over.

Could this be the problem?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Yes, you should enable the account and adjust any DNS records handled by CloudFlare to ensure the domain name resolves to the correct IP address.

Thank you.
 

tryingwebman

Well-Known Member
Sep 27, 2015
57
0
6
UK
cPanel Access Level
Root Administrator
Yes, you should enable the account and adjust any DNS records handled by CloudFlare to ensure the domain name resolves to the correct IP address.

Thank you.
I feel so stupid! Thank you for your help Micheal i really do appreciate it! What a foolish oversight on my part!

I am now getting an internal error page.

======
You don't have permission to access / on this server.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
======

Do you have a suggestion on how i can overcome this?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
I am happy to see the issue is now resolved. Thank you for updating us with the outcome.