Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Subdomains Working Wrong

Discussion in 'Bind / DNS / Nameserver Issues' started by NullyNuggat, Sep 20, 2017.

  1. NullyNuggat

    NullyNuggat Registered

    Joined:
    Sep 20, 2017
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    South Africa
    cPanel Access Level:
    Website Owner
    Hi There!
    After awhile with this website of mine it worked perfectly until today:

    What happens is when I create a new subdomain for one of the pages on the site it works only like this:

    https://page.mydomain.com

    instead of

    https://mydomain.com/page/

    like it used to. I get error 404 with the second one but it works with the 1st one.

    This has been frustrating me the whole day as I cannot find a resolution.
    Your help is appreciated!
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,427
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Do you have any custom Mod_Rewrite rules configured in the .htaccess file of the subdomain's document root, or in the parent directories document root?

    Thank you.
     
  3. NullyNuggat

    NullyNuggat Registered

    Joined:
    Sep 20, 2017
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    South Africa
    cPanel Access Level:
    Website Owner
    After reading about that .htaccess file, I just restored from a backup and it's back up again and new subs work right.
    I never changed anything someone just told me "the web died" and I found the weird thing with the subdomains.

    Thanks alot. If this happens again I will just manually check for that instead of restoring!
     
    cPanelMichael likes this.
Loading...

Share This Page