The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Success in database CONNECTION.....no TABLE created.

Discussion in 'Database Discussions' started by Scotty13, Jan 18, 2011.

  1. Scotty13

    Scotty13 Member

    Joined:
    May 21, 2010
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I’ve created_Table.php in Dreamweaver CS4 and created myMembers table in phpMyAdmin. When I test it in my browser, I get this error message….

    Success in database CONNECTION.....
    no TABLE created. You have problems in the system already, backtrack and debug!

    This is my table in DWCS4...

    <?php
    require_once "connect_to_mysql.php";
    print "Success in database CONNECTION.....<br />";
    $result = "CREATE TABLE myMembers (
    id int(11) NOT NULL auto_increment,
    firstname varchar(255) NOT NULL,
    middlename varchar(255) NULL,
    lastname varchar(255) NOT NULL,
    country varchar(255) NOT NULL,
    state varchar(255) NOT NULL,
    city varchar(255) NOT NULL,
    zip varchar(255) NOT NULL,
    phone varchar(255) NOT NULL,
    email varchar(255) NOT NULL,
    password varchar(255) NOT NULL,
    sign_up_date date NOT NULL default '0000-00-00',
    last_log_date date NOT NULL default '0000-00-00',
    bio_body text NULL,
    website varchar(255) NULL,
    youtube varchar(255) NULL,
    account_type enum('a','b','c') NOT NULL default 'a',
    email_activated enum('0','1') NOT NULL default '0',
    PRIMARY KEY (id),
    UNIQUE KEY email (email)
    ) ";
    if (mysql_query($result)){
    print "Success in TABLE creation!......
    <br /><br /><b>That completes the table setup, now delete the file <br />
    named 'create_Table.php' and you are ready to move on. Let us go!</b>";
    } else {
    print "no TABLE created. You have problems in the system already, backtrack and debug!";
    }
    exit();
    ?>

    I’ve tried everything, I cant seem to find what I’m doing wrong. Please help!
    Scotty13
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,481
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Deamweaver cannot create a database for you on the server. You'll have to create it in advance of connecting to it, via your cPanel.
     
  3. Scotty13

    Scotty13 Member

    Joined:
    May 21, 2010
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I did all that. ALL my connections are perfect. When building a table in myadminphp I setup my table under “members” In my phpMyAdmin / cPanel. I have members & myMembers under my database. I built my table in “myMembers” could this be my problem?
     
Loading...

Share This Page