The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sudden "unroutable mail domain" errors

Discussion in 'E-mail Discussions' started by GoWilkes, Nov 16, 2006.

  1. GoWilkes

    GoWilkes Well-Known Member

    Joined:
    Sep 26, 2006
    Messages:
    367
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    In an attempt to control spam, a few days ago I enabled the Tweak setting "Prevent the user 'nobody' from sending out mail to remote addresses..." After doing so, 2 of my 52 users reported a LOT of bounced emails, most of them stating "unroutable mail domain," followed by the domain of the email recipient.

    Apparently, they can send SOME emails, since they can email me (on the same server), but I do not know if the problem is sporadic, or isolated to anyone not on the same server.

    It's worth noting that both users use something like Microsoft Exchange. None of my other users have reported a problem.

    Assuming that the Tweak setting was the problem, I disabled it, but this had no impact. Since then, I have cleaned the Mail Queue (which only had 150 in it over 3 days; very low) and restarted Exim, but this also had no impact. Both users are still receiving the same errors.

    I read in the Exim FAQ that either the DNS servers are out of step with each other or the DNS library is out of date, but that is Greek to me. How do I go about checking to see if either is true, and/or correcting the problem if it is?

    TIA,

    Jason
     
  2. Manuel_accu

    Manuel_accu Well-Known Member

    Joined:
    Jun 19, 2005
    Messages:
    191
    Likes Received:
    0
    Trophy Points:
    16
    if you are referring to prevent user nobody from sending mails via script, then it is good idea to do so.

    For that you may need phpsuexec or if your clients are sending mail via script then they need to add SMTP authentication to resolve this issue.
     
  3. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Make sure that you do not have the following checked/selected?
    - WHM > Tweak Settings > Prevent the user 'nobody' from sending out mail to remote addresses
    - Track the origin of messages sent though the mail server by adding the X-Sender headers (exim 4.34+ required)

    You also need to de-activate and delete /etc/eximmailtrap
    Then run the following commands:
    /scripts/eximup --force
    /scripts/updateuserdomains
     
Loading...

Share This Page