suexec/mailman problem (modedit)

AlaskanWolf

Well-Known Member
Aug 11, 2001
535
0
316
Fremont CA
I am in the same boat as WildWayz, installed suexec and a titanic load of tickets about

[Tue Jan 22 14:59:38 2002] [error] [client xxx.xxx.xxx] Premature end of script headers: /home/yourroot/public_html/cgi-bin/script.cgi

xxxxxxxxxxxx
Time to disable suexec since it doesnt look like cpanel has a fix for these issues yet :(
 

Curious Too

Well-Known Member
Aug 31, 2001
432
1
318
cPanel Access Level
Root Administrator
I get the following error when trying to setup a new mailing list:

Mailman CGI error!!!
The expected gid of the Mailman CGI wrapper did not match the gid as set by the Web server.
The most likely cause is that Mailman was configured and installed incorrectly. Please read the INSTALL instructions again, paying close attention to the --with-cgi-gid configure option. This entry is being stored in your syslog:

Failure to exec script. WANTED gid 99, GOT gid -1. (Reconfigure to take -1?)

This is in my httpd.conf file:

# User/Group: The name (or #number) of the user/group to run httpd as.
# . On SCO (ODT 3) use \"User nouser\" and \"Group nogroup\".
# . On HPUX you may not be able to use shared memory as nobody, and the
# suggested workaround is to create a user www and use that user.
# NOTE that some kernels refuse to setgid(Group) or semctl(IPC_SET)
# when the value of (unsigned)Group is above 60000;
# don\'t use Group \"#-1\" on these systems!
#
User nobody
Group \"#-1\"

Should the Group be \"99\" ?

The server runs Redhat Linux 7.2
 

feanor

Well-Known Member
Aug 13, 2001
835
0
316
I have the exact same effect on about half of all suexec-instilled machines.....

It is my understanding that cpanel/apache/suexec bank on that httpd.conf config of the group ID being \"-1\".... so even if that is causing the mailman execution failure it appears to be required for the suexec environment to work properly?

I need to read more.
Anyway, this is still failling AFTER the fixmailmanwithsuexec script, etc, etc...... can we please have some guidance here?

Thank you!

:D
 

bert

Well-Known Member
Aug 21, 2001
593
0
316
Curious Too,

Try changing it to this (if you haven\'t done so already):

User nobody
Group nobody

Then restart apache:
/etc/rc.d/init.d/httpd restart

This should do it for you.
 

totalufo

Well-Known Member
Jan 17, 2002
160
0
316
I just ran into the same problem. CGI does not work. I commented out usr and group in httpd.conf and it works but I hope that this will be fixed. I don\'t know what caused it, it just happened? Maybe an update?
 
B

bdraco

Guest
/scripts/upcp
rsync -av rsync://rsync.cpanel.net/scripts /scripts
/scripts/fixoldlistswithsuexec


Running the above should fix all the urls inside mailman on previously created lists so they work with suexec..
 

xnull

Well-Known Member
Sep 9, 2001
156
0
316
:(

I ran both of the mailman fix scripts.. But all mailing lists still have this error

[size=1:40500744b6]Mailman CGI error!!!
The expected gid of the Mailman CGI wrapper did not match the gid as set by the Web server.
The most likely cause is that Mailman was configured and installed incorrectly. Please read the INSTALL instructions again, paying close attention to the --with-cgi-gid configure option. This entry is being stored in your syslog:

Failure to exec script. WANTED gid 99, GOT gid -1. (Reconfigure to take -1?)[/size:40500744b6]
 

awsol

Well-Known Member
Feb 8, 2002
578
0
316
Boston MA
In httpd.conf change the -1 to &nobody& . I did this and it fixed the problem. I also disabled SUExec Which I'm starting to wish I didn't. Hard to catch spammers now.
 

xnull

Well-Known Member
Sep 9, 2001
156
0
316
There is nothing with -1 in our httpd.conf... that's the problem :)

So are we missing a whole section of the conf file?
 
B

bdraco

Guest
[quote:d292d10e01][i:d292d10e01]Originally posted by xnull[/i:d292d10e01]

There is nothing with -1 in our httpd.conf... that's the problem :)

So are we missing a whole section of the conf file?[/quote:d292d10e01]

You shouldn't have a -1 .. not sure where they are coming from?? anyone know??

--

Are you having a problem with this ?
 

xnull

Well-Known Member
Sep 9, 2001
156
0
316
We seem to not have the bad stuff in httpd.conf but mailman still doesn't work and hasn't for a couple weeks.
 
B

bdraco

Guest
[quote:06bd010b15][i:06bd010b15]Originally posted by xnull[/i:06bd010b15]

We seem to not have the bad stuff in httpd.conf but mailman still doesn't work and hasn't for a couple weeks.[/quote:06bd010b15]


PM me your server info and an account thats not work and I'll fix it for you..
 

xnull

Well-Known Member
Sep 9, 2001
156
0
316
For those still having problems:

Nick fixed mine (thanks :)) and all it was is that the user was for some odd reason commented out in httpd.conf. Make sure root user nobody exists in the file, or you'll get that gid/uid error of it trying to find -1.
 

jumpdomain

Well-Known Member
Aug 12, 2001
109
0
316
I think the -1 group is coming from the CPanel install program when it installs Apache... All our 7.2 servers have -1 set as the group after we run the install script. I am pretty sure we do not install Apache when we install Red Hat so I don't think it is coming from an old httpd.conf file.
 

snowgod

Well-Known Member
Sep 23, 2001
70
0
306
actually, group -1 is the hardcoded apache default.