The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SuExec / mailman problems

Discussion in 'E-mail Discussions' started by rpmws, Jul 28, 2002.

  1. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    I started SuExec.

    ran all the fix it scripts. Tried deleting mailman and upcp. It doesn't reinstall it. I was going to copy back the data.

    My problem is that people can no longer access the admin or the list subscribe page through their domain name. Only using the master server IP or hostname as a domain.

    Is there around this.???
     
  2. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Hi-

    I think there are at least 4 or 5 threads about this particular issue if you do a search. (unless they got nuked by forum maintenance)
    ;)

    basically that is &by design& if you enable suexec.
    mailman can only run under one particular user account now, instead of nobody. So, it runs under the default hostname of your box in an attempt to make it anonymous in the only way possible, if you are using suexec.

    you could probably code something elaborate for this to get the functionality back, but I wouldn't want to try it.

    :p
     
  3. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    travis,

    I read all 13 posts related to this and now see it is by design. I wear that search thing out man :)

    But thanks for clearing this up for me :)
     
Loading...

Share This Page