The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SuExec not working?

Discussion in 'General Discussion' started by NetX, Oct 21, 2008.

  1. NetX

    NetX Well-Known Member

    Joined:
    Jun 18, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    I'm trying to avoid the user nobody to send mails, but when i try to compile php with SuPHP and SuEXEC, it looks done, but the mails still with the user "nobody".

    What can i do in order to ensure that the scripts be sent with the user thar runs the scripts instead of nobody?

    Thanks for your help
     
  2. darren.nolan

    darren.nolan Well-Known Member

    Joined:
    Oct 4, 2007
    Messages:
    259
    Likes Received:
    0
    Trophy Points:
    16
    Compiling is one thing, setting up apache to use it is another.

    Can you please double check for me that in root WHM, "Configure PHP and SuExec" - ensure that whatever PHP version you are using (or both) have SuPHP selected and nothing else (Not DSO, CGI, FCGI etc.).

    If it is - then do some quick checks to see if PHP is running as the user properly, write a quick script to write a file in the user's directory - check for errors.

    I like to create a PHP session, then go into /tmp and ensure the new file has been written with the right UID:GID (username:username). But only because I find it quicker.

    Cheers,
     
  3. NetX

    NetX Well-Known Member

    Joined:
    Jun 18, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    Thanks for your help, i had dso instead suphp.
    Now all is working perfect.
     
  4. darren.nolan

    darren.nolan Well-Known Member

    Joined:
    Oct 4, 2007
    Messages:
    259
    Likes Received:
    0
    Trophy Points:
    16
    :D:D:D Fantastic
     
Loading...

Share This Page