analog

Member
Aug 13, 2001
10
0
301
Ok, I have suexec enabled in my httpd binary, but when ever a customer tries to run a .cgi script I get an error 500. even with the permission correct, and the User and Group setting correct in httpd.conf. So, I decided NOT to use suExec, and commented out the User and Group setting in httpd.conf. Now, the .cgi scripts work just fine.

However, I added an account yesterday, and cpanel, re-added the User and Group settings right below the commented ones for a domain that has nothing to do with the new account I just added. This, of course broke their .cgi scripts, and they came kicking and screaming to me.

So, how can I prevent cPanel from re-enabling these User and Group settings?

Thanks!
 

zex

Well-Known Member
Aug 12, 2001
98
0
306
cPanel Access Level
Root Administrator
First running cgi scripts without user & group specified in httpd.conf means that all scripts are executed by uid wich runs apache (usualy nobody or www-data).
That means that every file created by some .cgi script or forum will have UID of web server and your user will not be able to manipulate with that file.

Second: Running cgi scripts with apache uid is UNSECURE and will probobly cause alots of trouble if you have at least 10 users.

Reason why scripts are not working with suexec is probobly in some suexec security checks (like: owner dir and files is the same, suexec is not compiled to be invoked with some other user name etc..) all answers are usualy in $HTTPD_ROOT/logs/suexec_log

If you have furthure questions about suexec issue please conntact me via e-mail.

P.S. if you want to disable update of users and group from cpanel you should disable autoupdate. But I\'m not sugestng that to you.
:cool: