The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

suexec turned on by default?

Discussion in 'General Discussion' started by AlaskanWolf, Jan 2, 2002.

  1. AlaskanWolf

    AlaskanWolf Well-Known Member

    Joined:
    Aug 11, 2001
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Fremont CA
    After installing cpanel myself, i noticed that suexec seemed to be turned on, i did nothing to turn this feature on, is suexec turned on automatically on a fresh install of cpanel layer1?


    any reason i should turn it off? no customers on this box yet but would like to know before we dump 500 accts from another box into it (that box does not have suexec running on it)
     
  2. WildWayz

    WildWayz Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    209
    Likes Received:
    0
    Trophy Points:
    16
    From my experience, SUEXEC killed MailMan and any Perl Scripts.

    Nick pointed out that every CGI-BIN should be 755 (Cpanel sets it up as 775 tho) - so once changed, the perl scripts then work, but MailMan still refuses to work.

    Try adding a single account and test out some bits.

    James
     
  3. bdraco

    bdraco Guest

    [quote:ae7a78de3d][i:ae7a78de3d]Originally posted by WildWayz[/i:ae7a78de3d]
    From my experience, SUEXEC killed MailMan and any Perl Scripts.

    Nick pointed out that every CGI-BIN should be 755 (Cpanel sets it up as 775 tho) - so once changed, the perl scripts then work, but MailMan still refuses to work.

    Try adding a single account and test out some bits.

    James

    [/quote:ae7a78de3d]



    Strange its set 755 in /scripts/wwwacct

    I wonder where the 775 is coming from ...
     
  4. bdraco

    bdraco Guest

    [quote:0d101046df][i:0d101046df]Originally posted by WildWayz[/i:0d101046df]
    From my experience, SUEXEC killed MailMan and any Perl Scripts.

    Nick pointed out that every CGI-BIN should be 755 (Cpanel sets it up as 775 tho) - so once changed, the perl scripts then work, but MailMan still refuses to work.

    Try adding a single account and test out some bits.

    James

    [/quote:0d101046df]

    Mailman should be fine if called by the hostname of the server.
     
  5. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Yea suexec is being instilled by default on any layer1 installs that have apache 1.3.22, and php 4.1.0......

    And the latest FP-upgrade, which is a part of layer1 anyway, it appears.

    At least that is what I\'m seeing from this angle.

    I\'m officially not cool with it.
    Please don\'t instill suexec by default...


    Danke.:(
     
  6. AlaskanWolf

    AlaskanWolf Well-Known Member

    Joined:
    Aug 11, 2001
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Fremont CA
    Nick, the server that we are moving customers FROM doesnt have suexec turned on, do you see any problems with a server to server move, the new server of course having suexec turned on

    If so, how do i turn suexec OFF on the new server so i dont have 500 accts yelling like bats out of hell
     
  7. bert

    bert Well-Known Member

    Joined:
    Aug 21, 2001
    Messages:
    602
    Likes Received:
    0
    Trophy Points:
    16
    This might be way to late and perhaps you already found an answer for it, but to disable it, simply delete the file and then run /scripts/initfpexec
     
  8. SplashHost.com

    SplashHost.com Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    delete what file?

    i need to get rid of this as well, my perl scripts are not working
     
  9. AlaskanWolf

    AlaskanWolf Well-Known Member

    Joined:
    Aug 11, 2001
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Fremont CA
    delete the suexec bin file
    revert your httpd.conf file to non-suexec format
    rerun the /scripts/initfpexec script
     
Loading...

Share This Page