simon templar

Member
Mar 28, 2008
15
0
51
Hi all,

I am trying to install SugarCRM on one of the domains I host.
I unzipped the files, and when I try to go to the subdomain, I get:




Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmamy.domain and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.





I did chmod all folders and files in 755. I tried 777 too. It's still not working.
Has anyone done it around here ?

Thank you
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Hello,

What's the exact error message you see in /usr/local/apache/logs/error_log when you notice that message in your browser?

Thank you.
 

Andrew W

Member
Apr 3, 2015
9
1
3
USA
cPanel Access Level
Root Administrator
Hi Jared/Simon,

I am facing the same issue now, can you please post your solution here. Thanks in advance.
Basic fixes to start with are checking file permissions and deactivating the .htaccess file.

Fixing file permissions can is very easy via SSH. Run the following commands:

cd /home/[username]/public_html
find . -type d -exec chmod 755 {} \;
find . -type f -exec chmod 644 {} \;​

500 Internal Server errors can happen because of issues with the directives in the .htaccess file. You'll typically find the .htaccess file in the same place you installed your CMS/CRM software. An easy way to deactivate this is to rename the .htaccess file into something like .htaccess.deactive

In cPanel you can easy rename the file from the File Manager module. Be sure you click the option to see hidden files. You can also run the following command via SSH:

mv .htaccess .htaccess.deactive


Try those few things and see if they work for you.