Suhosin Configuration Changes

nootkan

Well-Known Member
Oct 25, 2006
134
5
168
I am seeing this in my logs:
Oct 19 11:13:08 myserver suhosin[30765]: ALERT - script tried to disable memory_limit by setting it to a negative value -1 bytes which is not allowed (attacker 'ipaddress', file '/home/username/public_html/wp-content/plugins/nextgen-gallery/non_pope/class.photocrati_installer.php', line 163)
This showed up after a nextgen-gallery plugin update.

After reading through this old thread http://forums.cpanel.net/f5/how-do-i-modify-suhosin-settings-221842.html I am confused as to where to place my suhosin.memory_limit = 20 config change as there doesn't seem to be any definations as to where to place suhosin commands. Can someone shed some light as to where I can place the memory limit increase option inside php.ini. There doesn't seem to be anywhere inside whm either.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Hello :)

You should be able to add the entries directly to your /usr/local/lib/php/ini file. There is no specific location within the file where you must add the entries. If you want to keep the file organized, you could add the values under:

Code:
;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;
Thank you.