The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

suPHP Apache Issues

Discussion in 'General Discussion' started by Travis Vogel, Aug 14, 2015.

  1. Travis Vogel

    Travis Vogel Registered

    Joined:
    Aug 6, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Currently, I am having issues with my Apache Setup
    • Apache 2.4
    • PHP 5.5
    • MPM Prefork
    • Mod Ruid2
    • Mod SuPHP 0.72
    that issue being, I am unable to execute PHP scripts on the primary domain, - Removed -

    When I enabled Normal Shell* the scripts were executable, but I have shell-disabled for this account, and CGI-Access Enabled.

    Is this a suPHP permission issue, an account permission or something else? I will provide more information if requested. When you attempt to view the page, it looks as if there is Redirect Loop, but the .htaccess is empty, and should not be caused by that.


    Best Regards,

    Travis Vogel
    CEO of GamerGet, LLC.
    - Removed -
     
    #1 Travis Vogel, Aug 14, 2015
    Last edited by a moderator: Aug 14, 2015
  2. Travis Vogel

    Travis Vogel Registered

    Joined:
    Aug 6, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    **Update**
    So we tested some different Configure PHP and suEXEC parameters.

    setting the PHP 5 Handler to DSO, it works fine and executes the scripts.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    I'm happy to see the issue is now resolved. Note that suPHP is not supported with Mod_Ruid2, which is possibly why you had to switch to DSO. This is documented at:

    Apache Mod_Ruid2

    Thank you.
     
Loading...

Share This Page