The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SuPHP & Apache suEXEC still seeing nobody

Discussion in 'EasyApache' started by raptor235, Nov 9, 2011.

  1. raptor235

    raptor235 Registered

    Joined:
    Sep 13, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Toronto, Ontario, Canada
    Hi there I'm running a single server, I went through the headache of moving all the sites over to run on individual accounts to get in proper security and get rid of the nobody user. After all the work I'm still seeing the nobody user running httpd in top...

    I see all my accounts as well but why is nobody still showing? Any ideas of how I could track down where these
    proceses are coming from?

    Thanks
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Apache itself still runs as the nobody user for processes it initiates. PHP processes will run as the set user, but any Apache process (html page for example) is going to run as nobody. The only way to have all processes run as a user would be to use mod_ruid2 or MPM ITK on a machine under DSO, since these set Apache itself to run as the user for all processes.
     
Loading...

Share This Page