Support of TLS 1.3 - Questions

Operating System & Version
Centos 7.8
cPanel & WHM Version
/

Mark87

Registered
Jun 9, 2020
2
0
1
Italy
cPanel Access Level
Root Administrator
Hi, I hope your day is going well!
I'm not yet an CPanel user but i really have a question to ask.

Does CPanel support actually TLS 1.3?
I found this: Add Support for TLS 1.3, from that page seems the support has been added but TLS 1.3 is not the default.
From I can understand user can set TLS 1.3 as default from the panel.

I heard there is an issue with PHP IMAP extension and compatibility with the new OpenSSL 1.1.
I heard the IMAP extension has no more updated since long time and while is tried to compile PHP with IMAP extension and OpenSSL latest version 1.1 it doesn't work.

Is this issue resolved in CPanel? TLS 1.3 is supported only from web side or also email side?
How about have a Wordpress installation configured to send email by SMTP protocol? Will be used TLS 1.3?

Thanks for your time and help.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,297
1,251
313
Houston
cPanel does support TLSv1.3 for Apache only at this time. There isn't support for other services currently so IMAP along with cPanel services are not using OpenSSL1.1 currently though they are using a patched and updated version of OpenSSL 1.0.2k
 
  • Like
Reactions: Mark87

Mark87

Registered
Jun 9, 2020
2
0
1
Italy
cPanel Access Level
Root Administrator
cPanel does support TLSv1.3 for Apache only at this time. There isn't support for other services currently so IMAP along with cPanel services are not using OpenSSL1.1 currently though they are using a patched and updated version of OpenSSL 1.0.2k
Hi cPanelLauren, thank you very much for your reply!
You are not using OpenSSL new everywhere for the issue with IMAP?

I'm asking if the IMAP php extension will solve compatibility issue.
Seems OpenSSL 1.0 has ended his support on January 2020 but from what I know Control Panels has issues on upgrading with the "new" OpenSSL 1.1