SOLVED Suppress Disabled cPanel Backups Alert?

epaslv

Member
May 18, 2010
22
0
51
Melbourne, Australia
cPanel Access Level
Root Administrator
I am not a fan of the new backups system and prefer the legacy version. I only use 1 retention as the backups are rsynced offsite after local backups are finished. Here are the main reasons.

1 - When a daily backup is being performed, the removes days backup is only removed after the current daily backup is completed. This means the system will consume 2 times the disk usage. This is a deal breaker for me and means I need to double storage. The legacy backups don't have this overhead.

2 - The system also consumes additional storage for meta files, which are unnecessary when retention is 1

Since legacy backups are being removed, I resorted to running my own script that runs /usr/local/cpanel/scripts/pkgacct for each account which has been working fine.

The only issue now is keep getting the warnings below

warn [backup] Backup Not Enabled (This can be adjusted in WHM => Backup => Backup Configuration)

Does anyone know how to suppress this warning being sent?
 

24x7server

Well-Known Member
Apr 17, 2013
1,911
97
78
India
cPanel Access Level
Root Administrator
Twitter
Hi,

The warning will continue to be send unless you configure it. One way round for this would be that you configure this backup and unselect all the users from the backup list, so the backup will start and end in short time and you can continue with your own backup script that you said..
 

epaslv

Member
May 18, 2010
22
0
51
Melbourne, Australia
cPanel Access Level
Root Administrator
Hi,

The warning will continue to be send unless you configure it. One way round for this would be that you configure this backup and unselect all the users from the backup list, so the backup will start and end in short time and you can continue with your own backup script that you said..
I thought about this but its not a good option because as soon as a new account is created, backups for that account will be enabled by default.

You can't remove the backup from cron either, since cPanel just puts it back.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
The only issue now is keep getting the warnings below

warn [backup] Backup Not Enabled (This can be adjusted in WHM => Backup => Backup Configuration)

Does anyone know how to suppress this warning being sent?
Hello,

This comes from the backup cron job. You can delete the backup cron job (if it's not needed) to prevent it from running via the following command:

Code:
crontab -e
This will open the root crontab with your server's default text editor, which you can use to remove the line referencing the following command:

Code:
/usr/local/cpanel/bin/backup
Or, if you want to keep the cron job enabled, you can modify the line so that it looks like this and it will simply silence the alert:

Code:
0 2 * * * /usr/local/cpanel/bin/backup >/dev/null 2>&1
Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello,

To update, this is fixed in cPanel verison 68.0.16:

Fixed case CPANEL-16887: Backups: avoid sending cron emails when disabled.

Thank you.