The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Swap increased to 80%

Discussion in 'Workarounds and Optimization' started by ramindia, Apr 18, 2011.

  1. ramindia

    ramindia Well-Known Member

    Joined:
    Apr 3, 2011
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Hi My Swap Increased to 80%

    free -m
    total used free shared buffers cached
    Mem: 7943 7753 189 0 206 2679
    -/+ buffers/cache: 4867 3075
    Swap: 2047 1648 398

    free
    total used free shared buffers cached
    Mem: 8133716 7939384 194332 0 211344 2743820
    -/+ buffers/cache: 4984220 3149496
    Swap: 2096472 1688328 408144


    what is the solution to clear or do i need to extend swap ?

    any suggestions
     
  2. thecutecat

    thecutecat Registered

    Joined:
    Dec 20, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I also having the same problem. How to sove it??
     
  3. ramindia

    ramindia Well-Known Member

    Joined:
    Apr 3, 2011
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    hey

    i restarted apache, i see it solved let me know if that solution works for you
     
  4. ramindia

    ramindia Well-Known Member

    Joined:
    Apr 3, 2011
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Hi all

    But after 2days i see again Swap Increasing, what the Permanent Solution for the same

    any advice
     
  5. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If restarting Apache reduced your swap usage and available memory, then I would suggest looking into what is happening with Apache on the machine. You might start looking at your variables like MaxClients and ServerLimit, ensuring you have timeouts set for Apache, etc.

    You might also want to see what sites show the highest activity for Apache in WHM > Server Status > Apache Status area.
     
  6. ramindia

    ramindia Well-Known Member

    Joined:
    Apr 3, 2011
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Hi below is the report

    can you suggest me something to change


    Apache in WHM > Server Status > Apache Status area.



    i5 with 8GB Ram Cpanel, WHM
     
  7. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    You could reduce the Timeout and ensure you have KeepAlive on with a KeepAliveTimeout value set:

    Code:
    Timeout 20
    KeepAlive On
    KeepAliveTimeout 5
    Is your load actually high with high I/O wait times during the high swap usage?
     
  8. ramindia

    ramindia Well-Known Member

    Joined:
    Apr 3, 2011
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Ok let me change the settings

    yes its high load server
     
Loading...

Share This Page