Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

swapping from fcgi to dso/mod_ruid php wants to download

Discussion in 'General Discussion' started by dmacleo, Sep 9, 2012.

  1. dmacleo

    dmacleo Active Member

    Joined:
    Jan 28, 2012
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    56
    cPanel Access Level:
    Root Administrator
    everything I've read shows that this issue is due to easyapache not correctly compiling the php right, but I have redone it multiple times and tried php 5.3.15 and 5.3.16.
    I can swap to cgi, everything good. swap to dso and php files want to download.

    if this is in fact a mime issue what is best way to add this now?
    topics I found on it were older.
     
  2. dmacleo

    dmacleo Active Member

    Joined:
    Jan 28, 2012
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    56
    cPanel Access Level:
    Root Administrator
    the http.conf calls Include "/usr/local/apache/conf/php.conf"

    which has

    # CGI configuration for PHP5
    Action application/x-httpd-php5 /cgi-sys/php5
    AddType application/x-httpd-php5 .php5 .php4 .php .php3 .php2 .phtml

    in it too
     
    #2 dmacleo, Sep 9, 2012
    Last edited: Sep 9, 2012
  3. dmacleo

    dmacleo Active Member

    Joined:
    Jan 28, 2012
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    56
    cPanel Access Level:
    Root Administrator
    ticket 3157311 opened per licensepal
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,609
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    In that ticket, it was due to the following /usr/local/lib/php.ini setting:

    Code:
    ; Enable the PHP scripting language engine under Apache.
    engine = Off
    I changed it to the following and DSO began working for sites:

    Code:
    ; Enable the PHP scripting language engine under Apache.
    engine = On
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. dmacleo

    dmacleo Active Member

    Joined:
    Jan 28, 2012
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    56
    cPanel Access Level:
    Root Administrator
    still trying to figure out why that was changed as its not something I would needed to change.
    is it possible this is a default setting issue like the magic_quotes where the default off is actuall on?
    thanks for the help guys, overall was a good experience :)
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,609
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    The default for engine is On. It's the first option in the advanced mode for the PHP Configuration Editor in WHM. I don't see how that could be the same as the magic quotes issue. The default is On for php itself and for the editor. It wouldn't be something commented out.

    I could see how it could be accidentally toggled due to being the topmost option, though, which is the only way I could see it happening in that area.

    Also, you are very welcome. I'm glad we could track it down quickly for you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. dmacleo

    dmacleo Active Member

    Joined:
    Jan 28, 2012
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    56
    cPanel Access Level:
    Root Administrator
    well its possible I toggled it on accident, just seems odd but its working well now :)
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice