SOLVED Switching to LTS from version 70 STABLE

discostrings

Registered
May 7, 2011
3
1
53
Hello,

I am currently running cPanel version 70 STABLE and I'd like to switch to the LTS tier. However, Update Preferences tells me that the LTS tier is currently not available.

Has 70 LTS been released? Or has it not been released yet? I'm wondering if there is an issue with the updater.

I see that version 72 is now in the RELEASE tier, and I'm growing concerned that 72 could be moved to STABLE, at which point I would no longer be able to switch to the LTS tier.

I have been waiting to switch to LTS for about 8 months now as a result of the release schedule, and I really don't want to miss this opportunity.

Thanks!
 

SS-Maddy

Well-Known Member
Mar 28, 2009
122
13
68
cPanel Access Level
Root Administrator
@discostrings Out of interest, may I know why you are choosing LTS tier over other release tiers ? I mean why not Stable and turn off the automatic updates ? Would like to hear your PoV. Documentation says, LTS was scheduled to be released on May 2018. May be cPanel developers have a reason.
 

discostrings

Registered
May 7, 2011
3
1
53
Hi SS-Maddy,

I run LTS because I like to minimize the possibility of things being broken by new major versions when I don't have time to research and fix them.

With LTS, I can set aside time once a year during which I perform the upgrade and work through any issues. I can also learn about the new features and enable them as necessary. For smaller organizations that don't have many servers, this is a very reliable and efficient approach.

The Stable tier with automatic updates turned off would not receive security updates for most of the year. Keeping the server secure through these updates is important to me.

Your suggestion to turn the automatic updates off, at least for the moment, is helpful. I'll turn them off until I'm able to switch to version 70 LTS, then I'll turn them back on.
 
  • Like
Reactions: Infopro

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
8,847
741
263
Houston
cPanel Access Level
DataCenter Provider
hi @discostrings

The stable version should also be the LTS version but I'm noticing on one of my v68 test servers it's not showing either. What I did find that there was a case that addressed this CPANEL-20915 Update Preferences screen does not handle multiple LTS tiers correctly - this was resolved with v74 and backported back to v70. When was the last time you updated the version? I am curious if you just haven't received the update or if the issue persists.

Can you run the following:

Code:
cat /etc/cpupdate.conf
And let me know the output as well?


Thanks!
 
  • Like
Reactions: discostrings