Synchronize DNS zones from BIND to PowerDNS

sozotech

Well-Known Member
Jul 26, 2013
101
3
68
cPanel Access Level
Root Administrator
I am in the process of upgrading our DNS only servers which are running Centos 6 / BIND. I have setup a new DNS only server on CentOS 7 and it is setup to use PowerDNS.

I have clustered the old server to the new one as Synchronize Changes and the status shows OK. The new DNS server is set as Standalone. When I try to Synchronize all zones to all servers from the old server to the new one, no zones get copied over. I have tried pulling them from the new server by checking Synchronize all zones to this server only and Synchronize zones that are not configured on this server and again no zones are copied over.

I made an individual record update to a zone file on one of the cPanel web servers and it copied to the old DNS server and then to the new one so I know synchronization is working.

What am I doing wrong? Will it not synchronize all zones files unless they are both BIND or both PowerDNS?

Eric
 

ffeingol

Well-Known Member
PartnerNOC
Nov 9, 2001
438
107
343
cPanel Access Level
DataCenter Provider
The way that cPanel uses PDNS they have it configured for a BIND back end. That that basically means is that the zones are stored in BIND format regardless if you are using BIND or PDNS.

On your new DNS Only server, if you look in /var/named do you see all the zones there?
 

sozotech

Well-Known Member
Jul 26, 2013
101
3
68
cPanel Access Level
Root Administrator
No they are not there in /var/named. I do see a the zones that I mentioned I updated some records manually and did propagate.
 

sozotech

Well-Known Member
Jul 26, 2013
101
3
68
cPanel Access Level
Root Administrator
I managed to get the zones to sync by deleting the cluster entry of the new DNS server and re-adding and checking Synchronize Zones Immediately. I am not sure why it does not work after the fact....**Shrug**
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
975
136
168
cPanel Access Level
Root Administrator
Hey there! Are you saying it's still not working after you made that change? Were you trying to sync between two DNS servers?

Whenever a cluster isn't doing what I think it should I like to go to WHM >> Tweak Settings >> "Logging" tab on the web server and make sure that 'Enable verbose logging of DNS zone syncing" is set to on. Then you can watch /usr/local/cpanel/logs/dnsadmin_log while performing a sync of a zone to see if there are any specific errors being reported.

Once that log is set to "on" you can run this command to sync one zone to minimize the output to that log file:

Code:
    /scripts/dnscluster synczone domain.com
allowing you to further isolate the issue.