The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Syncing zones?

Discussion in 'General Discussion' started by Jasonbd, Jun 15, 2004.

  1. Jasonbd

    Jasonbd Member

    Joined:
    Jan 4, 2004
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Texas
    Hello,

    I know this is very unsupported and there are no docs on the cpanel-universal-dnsonly for WHM on a standalone DNS server. Though I had a question and wanted to see if others ran into this problem.

    First of all I configured everything on my Cpanel server (web1) I am not working on my standalone DNS server (dns). I installed the cpanel-universal-dnsonly for WHM on the dns server. I then went on web1 added the IP for configuring the cluster, setup the Access keys and everything. I went to WHM on the DNS server and saw in the configure cluster web1. I then proceeded to Sync 1 zone, let’s call it testing123.com. The sync failed, I noticed these errors in my logs.

    Jun 15 22:26:29 dns named[26394]: listening on IPv4 interface lo, 127.0.0.1#53
    Jun 15 22:26:29 dns named[26394]: listening on IPv4 interface eth0, 209.61.189.206#53
    Jun 15 22:26:29 dns named[26394]: listening on IPv4 interface eth0:0, 209.61.173.66#53
    Jun 15 22:26:29 dns named[26394]: listening on IPv4 interface eth0:1, 209.61.173.67#53
    Jun 15 22:26:29 dns named[26394]: /etc/named.conf:19: couldn't install keys for command channel 127.0.0.1#953: not found
    Jun 15 22:26:29 dns named[26394]: /etc/named.conf:19: couldn't add command channel 127.0.0.1#953: not found
    Jun 15 22:26:29 dns named[26394]: zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700
    Jun 15 22:26:29 dns named[26394]: zone localhost/IN: loaded serial 42
    Jun 15 22:26:29 dns named[26394]: running
    Jun 15 22:26:29 dns named: named startup succeeded
    Jun 15 22:33:37 dns named: named shutdown failed
    Jun 15 22:33:37 dns named: named shutdown failed


    I then ran /scripts/fixndc. This then fixed all the errors. I went ahead and proceeded to sync up the zone again. The output in WHM was

    Syncing ....Done
    Bind reloading on dns using rndc
    Bind reloading on web1 using rndc



    Synchronization Complete

    No errors in the logs. I went to /var/named/ and noticed there is not a testing123.db nor are there any signs of the file for bind.

    Does anyone have any guesses as to what happened or where I lost the sync?

    On my web1 server there is a testing123.db.

    On my DNS server I am running Bind bind-9.2.1-1.7x.2 with RH ES 2.1.

    All your suggestions will be greatly appreciated.

    Thanks
    -jb
     
Loading...

Share This Page