The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Syslog and exim_mainlog

Discussion in 'General Discussion' started by majoosh, Mar 7, 2016.

  1. majoosh

    majoosh Well-Known Member

    Joined:
    Feb 18, 2006
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    India
    Hi,

    I am setting up a syslog server. Does anyone know how to forward exim_mainlog to a remote syslog server ?

    Regards
    MJ
     
  2. syslint

    syslint Well-Known Member

    Joined:
    Oct 9, 2006
    Messages:
    249
    Likes Received:
    6
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  4. majoosh

    majoosh Well-Known Member

    Joined:
    Feb 18, 2006
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    India
    Thanks guys I figured it :)

    In case if anyone wondering how to do it just add the line below in the top section of /etc/exim.conf or update the config settings via exim advanced configuration editor.

    log_file_path = :syslog

    The above config will log messages both locally and to your syslog server.

    Regards
    Mj
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I am happy to see you were able to address the issue. Note it's important to use the "Advanced Editor" in "WHM >> Exim Configuration Manager" when editing the Exim configuration to ensure the changes are preserved.

    Thank you.
     
Loading...

Share This Page