System keeps generating backups on local server

kunnusingh

Member
Mar 23, 2010
18
4
53
Front of PC
cPanel Access Level
Root Administrator
I was using Legacy Backup which was gem of cPanel, It works perfectly but recently I switched to new backup system.

Issue I am facing:

WHM generate backup but instead of sending it to destination and removing completed backup it keep generating backup of other accounts. Legacy Backup was generating backup of account, Sent it to Destination and then delete backup from local server but new backup system is only filling my server.

What I assume it should work
It should generate backup, Send it to destination and remove then generate new backup.


My Backup Setting:
- "Retain Backups in the Default Backup Directory" is not enabled.
- I use "Strictly enforce retention, regardless of backup success." (Only 1 backup but as I understand it is only for destination backup and not local server because of "Retain backup in the default backup directory is disabled")
- Backup Type: Compressed.
- I am using sFTP and Destination is validated and enabled.


What I am missing? Even If cPanel failed to take backup of single account, It should moved to next account and generate backup, send it to destination and remove local backup.

Please help.
 

kunnusingh

Member
Mar 23, 2010
18
4
53
Front of PC
cPanel Access Level
Root Administrator
One thing I noticed that it was showing "backup completed" but it does not send all backups and it created at lest 20 backup accounts in local backup directory, Whenever I ran cPanel force backup it send few backups to destination and now only 12 backups are left.

Update: Now only 2 backups are left but why it does not first send backup, remove from local disk then generate another backup?


(It will fill my whole disk ;(
 
Last edited:

kunnusingh

Member
Mar 23, 2010
18
4
53
Front of PC
cPanel Access Level
Root Administrator
Hello @kunnusingh

If it's sending the backups, just slowly it sounds like it's working but there may be a connection speed issue, which would be related to networking. Are there any errors in the backup logs? They can be found at /usr/local/cpanel/logs/cpbackup/
Thanks for reply and updating my title.

There is no any issue with networking but I found some information about it on cPanel feature request section. It seems transfer with sFTP is slow but working fine for Google Drive, Amazon, etc user so I made my own backup script and its working fine as I wanted to work. (Take backup, Send to destination, Delete backup from local disk then generate new backup. It does not slowdown backup process because of I put limit of maximum 5 accounts can be generated before sending backup to the destination.)

But many many thanks for your reply and cPanel team for replying quickly to my support ticket.
 
  • Like
Reactions: cPanelLauren